So, WATCHDOG_RESET fault code anyone?


I have a pretty basic setup here… Its 6s1p battery, charge only BMS and Flipsky 4.12 ESC driving a single 5065 motor.

ESC is brand new, the issue I have is that every minute or two ESC stops responding during riding. The funny thing is that VX1 stays connected when that happens, so ESC is still on I guess, it just wont respond to remote inputs. Power cycle solves is, but a minute later it cuts again.

I’ve tried 3.65, 4+ and 5.1 Firmware, I’ve tried Sensored FOC, I’ve tried HFI because I’ve read that this error code could be related ti sensor interference. But the issue has not been resolved.

Motor : 1
Current : 0.0
Current filtered : 0.0
Voltage : 22.64
Duty : 0.679
RPM : 59.3
Tacho : 204
Cycles running : 0
TIM duty : 4560
TIM val samp : 3360
TIM current samp : 3360
TIM top : 6720
Comm step : 0
Temperature : 41.51

Any ideas?

1 Like

Out of my limited knowledge, watchdog errors mean out out processing power. What kv is the motor?

Edit: it may refer to out of resources, in general. Meaning voltage as well. I’d check for a start if the 5V rail is supplying 5V and the 3.3V one is supplying 3.3V


It’s evolve stock I think 150KV

@zhanzhan I think you had this error during zesc testing phase?

Try a different remote as a troubleshooting step. Preferably a PWM (“PPM”) style remote.

1 Like

Watchdog resets happen when you get bad current measurements, among other things

This is because the observer is unstable and runs up to infinity when the data are inconsistent, there’s several places where the code will hang because of this.

It’s a firmware issue masquerading as a hardware issue.


Well, that’s way beyond I can undestand…

What could I do to try to prevent it from happening?

Actually, try halving the observer gain during detection.

1 Like

for me It’s more like a hardware issue. after I optimizing the layout and filter, the issue disappeares. I guess the noise makes some numbers go to infinity. @Gamer43 he is right.


Same thing unfortunately… I guess I’ll trash this FS and get a decent esc.

BTW could it be that lover voltage (6a battery) is causing this? I am wondering if a 10 or 12s would make a difference

12s will make it worse. also be careful with 8302. It’s fragile.


Try what @b264 suggested. You can even use the same vx1 receiver in ppm mode.

There was a time when I also had these watch dog faults codes suddenly pop up at random.

I just connected the vx1 receiver to the neighbouring esc, still using uart. Didn’t change a thing other than that and it has been fault free ever since.

You can try this while at the same time order a hw6 esc :wink:


@b264 @Fatglottis

PPM Did the trick for now. Not a single cutout. Thanks a lot.

I’ve ordered ZESC from @zhanzhan anyways, I don’t feel comfortable with this flipsky, especially because this is a board fory 7 yo kid…

Thanks again.


Thanks for post this problem. I have also abs over current and mysterious booting from watchdog. Set uf 12s, maytech Remote esc Legacy, I think it’s the ppm . This time I use another remote , it’s work Fine.