[Q] Flipsky VX1 over UART


So I’ve recently bought a Flipsky VX1 after my winning remote broke.
Thing is, i can’t get the Flipsky to work over UART, over PPM it works like a charm.

I’m using a single motor setup and FOCBox (VESC hw v. 4.12 flashed with Ackmaniac’s firmware v 2.54)
I’ve tried setting the UART baud rate on 9600 and 11520.
Strange this is, when I set it to 11520 i lose connection over USB when turning on the remote.

My app settings in BLDC tool are set to :

  • Generat tab :
    –> UART (not UART and PPM).
    –> Status over CAN = not checked.
  • PPM tab:
    –> Disabled
  • UART tab :
    –> Tried 9600 baud rate and 11520.


Try it again with 115200, not 11520.

not at home, but I believe you have to define current with or without reverse in the nunchuck tab. Then it should react with your throttle.

On another topic, is it possible to get a PPM signal out of the VX2 and use UART for data only? (or even without UART)
For me it feels weird coming from PPM going to UART. It’s like my brakes went very soft in comparison to PPM

My instructions said not to plug the receiver in during programming. Afterwards the motors were actively braking till I plugged it in. Then all was well.

Thanks, tried it last night.
Sadly still no movement…

My mistake, meant 115200

Yea, same here. Did it like that, but no movement

Try swapping the tx and rx wire its reversed in ver 6 vesc.

Were you able to solve this problem?