Power Traverse - electric snowboard

Hi Esk8rs,

Was looking for help trying to optimize our vesc settings. Spent quarantine developing a swingarm based paddle system for snowboards.


I think we’ve got the traction down, now trying to work the bugs out of the power system.

Could use your expertise getting the torque @ startup, so the user doesn’t need to unstrap and push the snowboard.

The setup: 60v/1600w large hub direct drive, hall sensor FOC 60v 17s 35Ah 100A/50A BMS Flipsky 75/200

Seems like a config issue as one random config had enough torque to launch the setup before I lost the config.

See how it has no torque at all @ start

I can only push the motor to 37A before the motor starts to saturate.

Any help would be much appreciated, trying to get this thing on the snow to test.



Spent last night learning about HFI going to try…


Either use sensors or HFI, and since this is designed for wet use, I would not use sensors.

HFI also seems to work bad when motors get hot, so it would be perfect for a powered snowboard.


Try turning on traction control on if it isn’t. I know it’s one wheel but I had an issue with torque loss on the bench and traction control being off.

Also try messing with the throttle mapping curve. A positive exponential value will give you a boost at low throttle and smooth out at upper throttle. Shortening the postive ramping time may help as well.

Awesome project man. Good to see you here.


I had this exact same issue on the bench with the latest fw(5.1+). Cured with traction control as well.


Felt stronger with traction control on (5.1), but had more torque from 250w lime scooter motors @ 36v.

Something is a miss. I can’t figure it out, yet…

1 Like

What are your motor and battery settings set at?

37A motor saturation isn’t too high. Then again you’re running 17s so it should keep the amp draw down.

Anything else you changed component wise or only configurations?

You could bump your motor max amps to get a bigger kick at start before your battery amps catch up as long as your motor can handle it.


zero torque until it hits rpm.

I have had problems when changing throttle curves and ramping and mapping

Are you controlling esc with remote on the bench or with computer?

Ive had prob in past running direct from comp. of course never on a beast like this. Hope u figure it out i wana see this thing attempt to push snow. First time eating **** will be a blast.

1 Like

I can’t get my escs to run at all from the computer… I am using make though… could be an issue with that.

Yea, that is a similar hub motor. I will try your saturation suggestion today.

My cells are 3.6v fully capped off the cells hit 72.2v the controller has a limit of 72v. I originally tried 13s setup and had low-end torque issues. spent $$$ on a new battery and same issues :frowning:

Tried the 1600w version to try and keep the costs down but I can’t get it to take any amps. Anything more than 50 amps and I need to ease into the throttle to stop the cogging.

I’m thinking of getting the 3600w version or even trying the 120v version to pump more amps into it.

Really need to test this soon before running out of funds :wink:

1 Like


Plan on using BESC-G2 (20S) forked controller in production.

Need to get the prototype working before switching controllers.

Are you using hall sensors?

What firmware are you using?
It was not until FW5.1 that larger motors could pass the foc detection with usable values.
With earlier firmware it was a guessing game for larger motors to get parameters that worked.

Now I just need to push away slightly (wheel is barely moving) before giving full throttle and I run sensor less.

Your 13s should have been fine.

When you say the controller has 72V limit, you mean in vesc tool?
I think you play a dangerous game running that close to 75V.

Your issue should be related to the motor parameters you are using.

Mind sharing them?

1 Like


Here are the latest screens.


How should I be concerned about those voltage spikes? I get over voltage fault @ 72.2v and need to drain .2 for the VESC to pass firmware limits.

@Fatglottis Thanks for your help, I’m getting heat for not hitting the snow yet. These guys are anxious to see me fail. I’m going to throw as much power at this possible till it works. The original idea was to get cheap base price for users. Now we just need to prove the haters wrong. :call_me_hand:

I literally moved all my shit from the beach house to my parents garage to make this work. The goal is to move to Mammoth and make these with friends. Thanks


It sounds like you are exceeding the safe operating area, guaranteed

I get it, it had no balls, I pushed it to the max before reaching out for help. This started with scooter motors… I kept and power and redesigning around the failures. this is version 9.

I thought it had no balls due to using 48v with 60v motor. I bought the biggest battery I could find in the US trying to hit the mountain opening day. It got here and I am still stuck at home. :frowning:


Don’t base your engineering on your hype, base your hype on your engineering.

Sit back, take your time, and do what needs to happen for it to work properly. Use analog snowboard in meantime.

That’s my $0.02


Just sharing the struggle.

We have production sample packs ready, motor samples ready to ship. designing 20s VESC to keep cost down.

But, need to prove it works before we get to the next milestone.