Need help rebuild vesc six flipsky 6384

Hi all

15hrs into this i finally broke down. Here we go…replacing aps8072 with flipsky 6384. (Aps gave me lots of problems, loud noises and finally exploding cans). 12sp1 battery set up. Bestech Bms. I took whole board apart and put back together replaced all the parts that needed maint. I have vesc six (blue version 2 yrs old) i updated firmware to 5.1 or 5.01 or something. Then tried to set up FOC and everything worked except the ppm was acting strange. Like pins werent touching right. I have an rc mini remote never had a problem before…ever. So new servo cables, new aps remote, new canbus cables. I couldnt even get the aps remote to pair and actually gave up. It looked like it was pairing. Light turned solid on remote and recvr but wouldnt actually accelerate. Switched back to mini remote paired it worked fine brought outside, same result would cut out after 100ft or not work at all. I did this many times. Bench test would go great go outside drop board. Same behavior. Again thought loose ppm connection to vesc. Secured it with zips, tape etc. same result. Wiped firmware set up as new threw servo and recvr on the other vesc. Same result. Again and again. If i held it a certain way would work but was sketchy. Flashed vescs again connected to set up FOC ran motor detection and now the vescs just power off. Now im thinking FOC set up issue ive had my battles in past w that. Gave up FOC and onto BLDC motor test same result. Vescs just power off. Like its shorting the power to the board as im only connected to one vesc via usb yet both are going powering off. If i turn it off and on after 30 seconds vescs kind of blink then power off. If i let it rest 5 min vescs power on and stay on. However if i try to connect to vesc tool and set up motors it trips power. And there you have it…completely pissed and losing my mind. Appreciate anyone who takes time to try and help im beyond frustrated.

Original build specs

1 Like

First video was if I turned 10-30 seconds after power went out seems to fizzle out.

This video waited 5 min. Goes on stays on. Little green light next to blue turns on. Saying good to go.


If u guys could possibly take a look i would beyond appreciate it. Going nutz.

1 Like

First, the videos don’t work. Try using non-vendorlocked mp4 files or upload to youtube or another service.

Second, tell us what is the current malfunction. Like, what are the symptoms right now?

This thread is also miscategorized

Sorry been two years and a forum change. Can i edit category? Dont post too much. Currently just got vescs both reset on vesc six 6.41 firmware v 5.1 bout to try bldc settings then detection. See what happens. Videos arent too helpful just show vesc lights flickering out and then next one is them staying on. Currently they are staying on but havent ran a detection yet.

1 Like

So power just cut out without doing anything as i was going through settings. Tried to power on and no power. Then flickered now waiting to see if it will come back again. I did solder on a new on/off switch on bms old one fell off. Potentially shorting there?

Its def pointing toward bms ignition switch. Seems to be the issue i think…if i close the circuit seems to stay on. If I wiggle wires it shorts. Going to remove and resolder. Thanks for responding. This war is not over yet.

Hmmm? BMS could be faulty?

Or this…

Let me know if it works after resoldering it.

Resoldered same thing. Then just closed loop on bms w solder so it is always on and reconnected xt90 as power switch. As you know u get that spark when u connect it. So it went on no problem. 4 min later off again. Went to discconect and reconnect xt90 no spark no power. Id say bms is shot if power isnt getting through it. Have a bestech 12s hcx-d298v1. Any suggestion on upgrade? Surely something better has come out in past two years? This is so frustrating but we all go through it.

1 Like

100% BMS shot. Cleared all solder out where e-switch used to be and closed loop from bottom of circuitboard Shorted out again after a min or two. BMS must have some sort of delay to work again bc it will eventually work then cuts power. Just reading up on what bms are out there. Maybe ill post to see if someone has one.


To close this out for future people with similar issue the old bestech pcb had an internal lead in the pcb for b0/b- which is why there were 12 compared to 13. The new pcb does not have that internal lead but has a b-/b0 external lead that needs to loop to the equiv balance lead on battery one or if it cannot get to there at least loop to the b- contact on the bms that shares the connection with the main negative lead from battery one.