Need help configuring focbox unity

so finally just getting around to swapping out focboxes to unity, but can’t get it to configure properly.

configuring for FOC, R + L detection seems ok, but it fails on λ detection, the part where it asks you to spin the wheels for flux linkage. i keep getting “Flux Linkage Measurement Failed” in FOCBOX-UI, and “Could not measure flux linkage properly” in FOCBOX-TOOL.



these are the only two topics i could find on the matter, neither of which are helpful at all:

it’s not the motors, no issues when i use focbox.

any help would be appreciated.


I had that issue before, I just full power cycled the board and phone, worked after that

Holy motor resistance, Batman.

1 Like

Similar issue recently as well… I just swapped My wiring from unity “motor 2” side motor 1 side and the issue followed the wiring so.not the unity totally… And not all halls recognized… But may have to unwrap the wiring from the flex braid to see what up =

Did you solve this? Having the same problem :frowning:

yea it was the dumbest thing.

iirc i was spinning the motor by spinning the wheel, since it was a direct drive. so instead grabbed the motor itself and spun it, and that worked.

1 Like

Oh, I’m afraid for me that will not work as I spinned the motor itself, will see on Monday when I can do more tests!! Thanks for the response :slight_smile:

1 Like