Motors wont spin after successful config

Hello. I built an eSkate about a year ago and I haven’t used it in two months as I broke my arm. I recharged it and the motors slightly humm but don’t spin. I did a reconfigure using VESC tool and the motors turn normally and complete the test with success. I then attempt to use the controller and the same humm happens without movement. Any ideas for troubleshooting? Thank you in advance.

Flipsky VX2
Dual FSESC4.20 Plus


I should also say, after successful calibration, the forward/backward buttons don’t work in VESC either. The only movement I get is calibration testing.

Sounds like your throttle needs to be recalibrated.

This is what it sounds like after a successful motor test and normal ‘spin up’.

Link: skateboard - YouTube

Have you tried changing the “app to use” in the vesc tool? I get this on my vx2 if its set to anything other than uart.

Sorry, I am not sure what or where “app to use” is.


How do I perform a throttle calibration in VESC? Thanks.

+1 to throttle calibration. If you’re using the latest mobile VESC tool on the front page choose setup input. Mine didn’t spin up until I did that.

I tried the calibration; however, still couldn’t get it working. Nothing shows on the input graph when I am moving the throttle rocker. Any other suggestions as I am sure it must be a setting? Here are the results of the detection process.

Wait doesn’t that mean your remote isn’t connecting then? That might still be the problem if you can’t get the remote calibrated

1 Like

Ok so under the right side column ull see APP and the click around under the settings tabs until you see a drop down for app to use and try ppm then uart then ppm and uart and what not.


No, it won’t connect. I have never had trouble in the past, anything else to try? Thanks.

Ok just so we’re on the same page you’ve already tried this right:

And when you say it’s not connecting you mean the remote isn’t connecting?

I got the motors working when I test in VESC by adjusting the voltage cutoffs, but still no cigar with the remote. The VX2 says is connected but doesn’t do anything. Yes, I have gone through setup input but nothing appears to happen.

Check your controll type, make sure your APP is set to UART and that you pick any of the right controll type for you, like “current smart reverse”


I mentioned this before but went over


Sorry, yes I tried this too. It also didn’t do anything. I’m leaning toward a dodgy controller.