Motor Temp cutoff still limited in no_hw_limits version of firmware

Hey all, I’m trying to use the no_hw_limits version of the 5.2 firmware so that I can set some values above what vesc tool allows, (i.e. >120C motor temp cutoff). However, when i finish uploading the no_hw_limits version from the firmware tab, nothing changes. I still cant edit the values as I want.

I’m currently on 5.2 firmware on a flipsky 6.6 mini. Anyone help me out?

Upload a bootloader and try again.

So I went to the bootloader tab and uploaded the bootloader listed in there “60 & 75_300 & HD60…” and then retried uploading the no_hw_limits firmware again. Still no change. Anything else I can do? wth is wrong with my esc, everyone else does this so easily lol

It looks like the hardware limits disable, disables these limits:

  • motor current
  • battery current
  • absolute current
  • input voltage
  • ERPM
  • minimum duty cycle
  • maximum duty cycle
  • FET temperatire
  • Current Filter Constant

So motor temperature is not on the list of limits that can be disabled.


Well that’s silly


Think I will just depin the motor temp wire for now until theres an easy workaround in software. Thanks @b264

Like @b264 said even with hw_no_limit it’s not possible to set it more high.
I tried it as well just some days ago and 120 is the max you can set it up to.

1 Like