Motor Issue - Loud screech sound (now a Unity hardware issue? TBD)

basically I was commuting home today all of a sudden it felt like the tire locked up or the wheel, but I continued on at a slower speed and it felt okay. Once I got across the bridge I was able to take a look at the wheels and see what was going on. One motor wasn’t operating properly so I tried a couple roadside motor detections and things got worse. So I limped home on one motor. Unfortunately my stupid meter app did not auto start recording so I don’t have any Telemetry to show if that would have helped at all. In the video you’ll see I do a motor detection, sensor wires are plugged in, there are no issues with any of the phase wires touching and if you know the sound that it’s making and have any ideas feel free to let me know. These motors are fairly new as I got them during the group buy from hyper ion over the holidays iirc

Screen shot of first detection both motors

Screen shot of the just the working motor attached and the problem motor unplugged completely



wheres my motor “whisperers” =P

Why do you turn the motors by hand ? Is this a unity thing ?

Did you change the phase wires around ? did you also try connecting the cables from motor 1 to motor 2 ?
Did you try running sensorless to see if the noise persists ?

When you hold the disconnected phase wires together and turn the motor by hand do you feel a resistance on any cable to cable combination ?

So your first screenshot… “first detection both motors” was after it had an issue already?

Those hall sensor results look funky to me. The motor resistances are also HUGELY different. Motor 1 looks like the cause of the issue. Now to pin down if it’s the motor or the unity port. Like @ryux suggested, switch motor sides and see if the issue follows the motor or the port.

Here are mine for reference:

Do you know/have any screenshots of a setup when everything was good?

Sexy motor whispers


in this pic everything ran good… but the motors were plugged in opposite… so in was is NOW motor 1 and 2 was the opposite…you get it im sure… so i swapped sides and it followed the motor…now here we are so far…

regardless up until yesterday they were running smooth and strong and I put crazy miles on my board weekly plus a road trip this summer where I logged miles.


1 Like

yeah its the recommended way, but can still work with belts on and all that jazz…everything was just torn down for trouble shooting

didnt swap sides as per reply to venom

yes no change

yep gave this a try and resistance was increased, release connection and goes back to a free spin…

I dont have my wires marked 1-3 so very likely after plugging/unplugging the few times that the order has been changed.


1 Like

The motor resistance and inductance look good. Points me towards the sensor cable from the questionable motor.

also Im new to the metr app but know in expert it can read motor configs and what not…what any of that info be useful if i were to run detection again and save the info…then comeback and screen cast/record that?

the cable or the pcb? its still acts weird unsensored

I’m looking at the hall sensor image of the dots and circles specifically.

So in the unity app, does motor 1 always fail that diagram? Like if you swap the sensor and phase wires from the left motor to right, would “motor 1” still fail or would unity show “motor 2” failing?

1 Like

You could also try to measure the hall sensor states with a multimeter


Found this pic on another forum - not sure if it fits the maytech


So you should have 5V and the 3 Hall sensor pins

Each of the pins and above high/lows represents a pin in either 0 or 1 state (S1-S3 or VWU in the below pic)


Also can you change from BLDC to FOC or from FOC to BLDC on the unity and try detection again ?

yeah it followed the motor which is why i had swapped the inputs in the first place to isolate it… yet it runs quiet and smooth… wont be home till tonight to further inpections… i mean I could keep running detection right now to see what results come about, but regardless till i get home… motor 1 is unplugged and motor 2 is the work horse…

on the bright side if anyone is interested in building a single drive AT board its possible but at 20/60 not very exciting lol…

1 Like

unity app doesnt give an option to select foc/bldc i assume it auto detects whether there is sensor input unless Im missing something…

So good news I guess. Check this shit out, so I crack open the case I swapped motor 1 and 2 on the unity input, ran motor detection again and the issue stayed with the motor one pinout. So motor 2 which was the good one started screaming just like the other one did. So we either have a hardware or some kind of firmware issue on that port only. Luckily I had another build I just wrapped up so I pulled the unity out of that really quick because luckily that was a top mount box, thank God for those I guess, plugged that in ran the detection… everything went like butter except for the flux detection that still fails for some reason but here are a couple screen shots as I ran through each detection. I have a video for you guys I’ll post it up tomorrow when I have free. Thanks thoughts?

First pic… Problem unity…motor wires swapped…

New unity… Motor 1 and 2 plugged in properly:

1 Like

I think the problem unity has a similar issue that my original unity had. They had me mail it to Bara to solder a resistor correctly.

My Flux linkages (lambda symbol) were mismatched and followed the unity port.

It’s odd that the new unity still had a hall error. Are you using any cable extensions or adapters?

short answer yes, flipsky extensions…

long answer one motor I had to solder the extensions on cuz they shipped me 1 motor with the sensor wire that are supposed to plug straight into the vesc…great idea if you your front mounted… shitty for rear as u cant use the needed extension wire. IIRC motor 1 has soldered sensor wires…

on the other build where i pulled the new unity, sensor readings were good (TB motors) and since its a top mount box I used ethernet cable as extension wires… flux detection was also fine…

Maow!..feed the cat

remove hall sensors try detection again. Also wtf is with that manual rotation? :rofl: official VESC7 feature?


Do you have why other hall sensor cables you could try? Or can you remove extensions and try?

hmm i dunno if i have any more extensions around…and OE sensor wire from motor wont reach in rear mount =/

Yeah I feel you, disassembly is crazy annoying