Motor detects, but doesn't spin!

Hey guys, i bought a scooter for my gf to ride in!! I bought a broken scooter because it was several times cheaper than a new one and I figured that with a vesc I could just replace the controller and almost call it a day.

It turns out I was wrong… Yet again😅

My problem:

I run detection, everything detects, values seem fine but motor doesn’t make any noise nor moves.

I figured it was because I didn’t connect hall sensors, it turns out it wasn’t that.

So I’m left with a cable mess, a sketchy setup and no idea of what to do anymore.

I need help!

(Solder joints are temporary as connector will need to be removed shortly so please no judgement)

I should add that I’ve tried all types of motors in motor detection, I’ve also done the foc detection by hand. And I tried to run it in bldc with no success.

1 Like

I didn’t know vesc can even pass motor detection without moving the motor. Wtf? :laughing:

Maybe battery is empty / battery cutoff is wrong, so the vesc doesn’t want to drain it?


Is that Hank Hill’s Esk8??


I will check that, but battery it’s almost full as I just finished rebuilding it and testing it for any faults

I don’t even know anymore :joy: i will check with my unity tomorrow to see if it does the same thing

Lmao, i just thought that it’s maybe not the best idea to work on top of the gas container (it empty don’t worry guys) :rofl:

1 Like

Did you ever figure this out? I just had almost the same issue, my motors spun fine and detected perfectly normally during motor detection but when setting direction neither motor spins.

1 Like

What firmware version?

Wired or wireless connection to the ESC?

FW5.3 and tool v3.01 over USB

I’ll try FW5.2/v3.00 when I get back to the board

Old thread, but

The values of the motor detection do look very much off.
Depending on the motor size, it should look more like that:

1 Like

My values look like that, it’s weird, on the direction setting stage of the wizard the motors wouldn’t turn and made a horrible screeching noise. They detected and spun fine in detection and worked just fine on the road, I just couldn’t spin them in the wizard.

1 Like

No :disappointed:

I was testing a scooter motor on a foxbox, and I determined that it was probably too big to work with such old hardware. (The motor spinned perfectly with other escs)

Its true lol, way to high values… You have to take in account that this is a very low kV motor and that it is bigger than most motors that we normally use (in size not power)

1 Like

What hardware are u using? Vesc and motor.

MakerX DV6 Pro and Flipsky/boardnamics 6384 170kv

That’s very odd. I would try reflashing firmware if I were you. Trying without sensors plugged in as well, in case those are the issue somehow.

1 Like

I wouldn’t use beta software while troubleshooting. Use a known stable version.

TFW 5.3 is still considered beta and not stable despite being the FW this VESC shipped with

That’s an issue between you and the vendor. You decided to pay that specific company. Some are better than others, especially when it comes to software.