Metr problems Please help

Recently brought a metr non pro version from someone on the forum and for some reason no data comes up when I connect it to the metr app

I think the problem might be got to do with tx and rx
Do they have to be switched or something

Please help if possible

Two things I did to fix mine was update the firmware and then plug it into the slave. For some reason that worked for me and my friend too :woman_shrugging:

1 Like

Pictures of your setup helps.
Also try to switch rx/tx is worth a try…
Did set up your vesc to the right baudrate and selected uart?
That’s nothing special by the way and can be found in the existing metr threads.


I actually haven’t used the vesc app yet and will check that now

What baudrate should it be on

Setup is for the moment

Single vesc6 trampa

12s5p battery

Metr plugged into uart

Baudrate 115200bps

Baudrate set to 115200 is correct for old Metr modules. With Metr Pro the baudrate gets auto detected.
As @Andy87 said make sure UART is enabled in VESC settings and TX/RX connected in the right order. The Trampa VESC6 has it swapped compared to the 4.12 hardware.

With Metr Pro RX/TX also gets auto detected.

So tx is in t port and rx is in rx port

So that should be fine or should I still try

Swap them.


Thanks a lot


You just made another friend… same thing worked for me.


For me it was just a tx/rx issue which got fixed when swapped them around

1 Like

To my understanding that does not make a difference with the Metr Pro.

1 Like

I had an old metr module (non pro)

1 Like

Glad I could help :+1:

1 Like

Update the modules firmware from within the app. Make sure you’re updated on vesc, app, module.
Check baud rate

1 Like

I updated the firmware. Does the baud rate matter on the metr pro?
It now works on both sides, but on master side voltage readings are random. And in both sides, modes are only applied to the respective side.

1 Like

@hexakopter @rpasichnyk

So, I spent a large part of today figuring this out. @pookybear was super supportive and helped me a ton. I can’t express my gratitude enough!
It seems that the boot loader is broken on one side, and can’t even be flashed with SWD because the rails seem to be (internally) shorted… I’ll have to chat with some wizard-like-being to see if there’s any hope for this to be restored.

1 Like

So I just found out my metr works fine on the slave, but my davega worked fine on the slave as well, and now my davega doesn’t work on the master, so both davega and metr do fine on slave and don’t work on the master,

What can I do?

1 Like