Meepo V3 Shuts off randomly

previous owner stated that it’d turn off riding really rough. I had it turn off riding flat on the street. I’ve done some reading up and it could be both the BMS or the ESC. The fact that unpluging and repluging the battery in makes it work leads me to believe that it could be the ESC, but at some point the BMS’ power button wasnt responding as well (press power to see battery %).

Anybody have any ideas, or any experience with this?

Can you tell if it happens only under load or even on the bench?

1 Like

ok so same thing happened to me and i spent like a week trying to work out the issue before realising i hadnt charged the remote
not saying thats your issue but please think if you have done that recently

also what voltage are you getting out the battery?

only under load. just slapped it around a couple of times while running it on the bench, kept running. hasnt happened on the bench before either.

@Halbj613 The thing is the board would shut off, not the remote. Charging the remote now anyways.
i have 41.7volts out at the battery right now.

1 Like

I bet on the bms crapping out. Got a spare battery?


What meepo battery is it? The standard?

From what i’m seeing now that I’ve opened this up and taken a look at the wiring, i highly doubt it could be the BMS.

Meepo runs their batteries directly to their ESC, so the output load doesn’t go through the BMS and directly into the ESC. i.e., with this wiring setup, there’s no way for it to be the BMS.

which kind of blows because new ESCs are $80 and I like this remote. These remotes only work with meepo ESCs right

@Skyart yeah I think this is the standard. Odometer on remote says 160km.


So the vx1 and vx2 are reasonably similiar style

Also that isn’t true
When my bms broke the board wouldn’t turn on at all

Check the bms to make sure

The only way to be sure that those leads go directly to the battery is to take off that heat shrink, I have s feeling it’s a discharge bms


I’ve had a similar issue, my board was under warranty tho, and they sent me a new batt

1 Like

Yup, i think so too. It would be weird if meepo uses a charge only bms.


You guys might be right. There might be a separate BMS inside the pack since it’s sealed. Also, fun fact, theres a solid chance the pack got wet.

Also if I recall correctly, when this happened on my backfire g2s, it was the BMS as well.


Once i had random shutdowns of esc(not remonte), wasn’t any extreme load, just cruising from work. I was sure my battery bms was on way to say goodbye. But then I checked esc and positive wire of xt60plugg was pressed by power button causing short when riding on bumps or rough road.
Note that power button housing is metal and wire was hard pressed to show upp first raw wires in cable.I think it was my assembly error from past because you need push xt60 plugg close to esc with finger before completely attaching enclosure.

When board had short and switch off remonte didn’t show current speed and didn’t react with vibration as usually when battery low.

After fixing wiring and properly attaching enclosure didn’t happened more to me.

1 Like

unfortunately that’s not the case with mine. all wires are neat and tucked properly :confused:

1 Like

Just ran it a few miles and it shut off randomly. Battery voltage reads at 23 volts, this is just looking like a pack of old/fucked batteries.

Surprises me because I barely even pushed it 2-3 miles is a ridiculous number for something at 160km on the odo

23 volts is very close to death. I’m not sure if the LingYi esc has a voltage cutoff or if its just the bms. There’s no way 23v is normal. My hobbywing esc is at 1 1/2 lights at around 35/36ish volt

thats 100% the case…
their BMS’s are always sealed in the battery pack

1 Like

Yeah that’s 2.3 volts/cell. When I just tested today without charging it showed at 39.5 volts overall which is a lot more likely than 23 volts. I don’t know why waiting would pull it back up or what about the BMS went wrong, my knowledge simply cuts off here. I’m just gonna say faulty BMS and try to repair from there.

Does anybody know any cheap charge only BMS out on Amazon or eBay?

1 Like

Where are you located if in EU

@tinp123 might have something

If US maybe @Skyart

Hi everyone,

It’s been 2 years now on this post but I have the exact same issue now on my V3 ER and wanted to know if you found the solution.

My board stopped 2 times almost at the same location, luckily 100m away from my home.

  • power button not responsive
  • battery indicator not responsive
  • remote still on but disconnected (logic as the board is dead)

While it is still “dead”, I tried to plug the charger, still not working even if indicating 100%.

Dismount the battery cover, unplug it and replugging it and it works again. Indicator says around 35%, and everything works fine again.

I could drive it again and it happened a second time, at the exact same location after riding the same way (home work-work home (almost…))

The battery humidity indicator is red also.
So I would tend for a dying battery.

I have to try again but it seams that I am only able to charge the batterie when it is disconnected from the ESC.
I will try again tonight.

Any idea what it could be?