MakerX D75 CAN no longer works after CANBUS connection

Sorry for the long read, and I really appreciate the help, but I’m going to get detailed to cover any questions.

I have two MakerX D75 dual vescs I’m trying to connect over CANBUS (front and back for AWD). After I checked the vescs to make sure all CANS were detected, I unplugged the power to both vescs and plugged in my CANBUS cable, which consists of only the CAN-H and CAN-I, and H going to H, and I to I. When I plugged the vescs back in, the left side of the front vesc was no longer recognized by Windows over USB and Vesc Tool didn’t detect it. This is the side the CANBUS is on. When I plug the USB into the other side, it’s immediately recognized, but only shows the CAN for that side.

This is the second vesc to do this, and there’s no ground loop or anything questionable connected.

The following is what I just sent to MakerX Support:

"I received my new D75 today, but we’re having problems with one of the sides again. I don’t know if this is the same issue though.

The problem is that both sides of the new vesc were initially being recognized in Vesc Tool 3.01, but after connecting the CANBUS cable, one of the sides of the new vesc stopped being recognized, even after disconnecting the cable and rebooting the vesc. Here’s exactly what we did:

On the rear vesc (older) I have the motor cables, hall data cables, and a bluetooth receiver plugged into the right side 5v port

On the front vesc (new) I have the motor cables and hall data cables connected, the MakerX power button plugged into “sw” port and it works properly, a flipsky vx4 remote receiver, and a MakerX bluetooth receiver. We did not have power or the CANBUS cable connected yet.

  1. Connected power to both vescs

  2. Started Vesc Tool and made sure all four sides were being recognized properly and all had firmware version 5.3, but we didn’t have the two vescs connected yet, so this was confirmed by moving the usb cable to the other vesc

  3. Made sure that all the receivers had lights

  4. Disconnected the power cables

  5. Connected the two vescs with the CANBUS cable. Can-H went to Can-H and CAN-I went to Can-I. No ground wire is present, and I tested the continuity of the CANBUS cable’s wires

  6. Connected the power to both vescs, and the USB cable was plugged into the left side front/new vesc port. After powering on the new vesc with the power switch, everything came on as expected, but I did not get the Window’s chime when it detects a new USB device is connected

  7. Opened Vesc Tool, and it would not detect anything

  8. Unplugged the CANBUS cable

  9. Unplugged the USB cable and plugged it back in to the same port, but neither Windows nor Vesc Tool would detect it

  10. Plugged the USB cable into the right-side USB port, and Windows detected it as well as Vesc Tool. However, Vesc Tool was only detecting the side the USB cable was connected to, not the faulty side

Then we tried a number of different things:

  1. Disconnected everything and left the vesc unplugged for a minute

  2. Plugged in the power and USB cable to the side not working and it still wasn’t being detected

  3. We checked the voltage of the ports, and the 3.5v port on the bad side wasn’t showing anything. Everything else was fine.

  4. Checked all the ports on the working vesc and they were all working

We made sure every step was done carefully, and absolutely didn’t ground anything out or have the incorrect pins connected. We checked the connectors of every connected device beforehand to make sure they were correct, and rechecked them again after the problem."

Anyone have this issue before? I’ve been reading of people having problems with the D75 CANBUS ports. Is it possible that the rear vesc is somehow overloading the 3.5v rail, even though it’s just the two data pins connected?

I have no idea why the bottom paragraph is bold. I didn’t do that, lol

Change the CAN ID of one of them to any other number and see if that works

I had tried that, but no luck

1 Like

iirc there was a fw issue on vesctool regarding not detecting the 4th esc when chaining canbus, i think it was resolved in latest vesc fw, but idk if makerx is already up to update on their custom fw

If it matters, you can search for “markdown formatting” and find answers :grin:

The problem is that the bad side USB is not being recognized by Windows anymore, whereas the other USB port still works. So it’s not connecting to the bad side in Vesc Tool (3.01) so I wouldn’t be able to flash it.

Are the green run lights on both D75’s lit?
The battery cables of the two ESCs need to be connected in parallel before energizing them together, otherwise the CAN chip will be damaged.

I have mentioned it in the newly written FAQ page. More will continue to be updated…


Yes, the lights on both vescs are lit. The information on connecting the canbus comes a bit late. Can it be repaired? I’ll use split ppm if so. I already sent one back to you, which you should have now.

Communication delays?

1 Like

What I mean is, if you have a product with a component that requires a very specific way of being connected, otherwise the unit will be damaged, a warning about how easily it can be damaged should be right there where “CANBUS” is listed as a connection on the website.

Do the lights indicate that it can be repaired, or is still useable?

Are the green lights on both ESC on or is it just green on one and blue in the other?

1 Like

Both are blue

Both vescs have blue lights

I believe that means something is blown, but I’ll let David confirm.

Do you know if its something that can be repaired?

When mine was doing the same I sent it in to get repaired by David. Mine was something else, I don’t know if CANBUS chips are also easily repaired.


Canbus chips are fairly easy to replace with a hot-air station. Finding Canbus chips with the right specifications is more challenging.

1 Like