Loss of power in one motor

I’m having some problems with one of the motors has alot less power than the other one, to the point that I can stop it with my hand while the other one stays strong and stable, there are also some stuttering noises but it’s more like it’s loosing power rather than something is stopping it

I’ve gone through all the settings in the vesc6’s and they are the same on them both, I’m not quite sure how to troubleshoot this, I ran the motor detection and it went fine and I haven’t gotten any faults

Looks like a @Trampa setup. Maybe Frank can help you.
Did you check all connection points?
Maybe a lose bullet connector or bad solder joint somewhere.
What was the result of the motor detection?
Both motors had similar values?

Surefire way to check if it’s the controller or the motor is to switch them. Swap the connections between the motors and their respective controllers. If the same motor continues to have trouble, the motor’s bad. If it switches to the other, the motor controller is either bunk, or needs to go through the setup again.


I bet on bad bullets or a cracked solder joint someware.

I would try to reflow the solderjoints on the motor and ESC bullets. Maybe try -if you still use “banana plug style” bullets- to use the “solid” style instead. The “banana plug style” tend to be unreliable from my experience andwhich caused a bunch of over Amp errors for me .

Just to visualize it :wink:


That is on the bench. The VESC is current controlled and needs resistance to show proper functionality. There is also traction control which acts a bit like a electronic differential.

The only way to tests things is riding the board. If the motor wizard shows similar values for both motors, the system is probably fine. A bad connection would show substantial differences. Another thing one can do is run the motor wizard several times and see if the results are similar all the time. A bad connection or broken winding would probably cause fluctuations in the wizard results. Maybe the hall sensor on one motor has a problem, could also be the case. If you rev up the motors you would see if it is only an issue at low RPM. Hall sensors are only used at low RPMs. At a certain RPM the VESC switches over to Back EMFs and deactivates the Hall sensors.


Check the bullet connectors, sensor wires/connectors and make sure any conductive parts of the bullet connectors are not touching eachother.

1 Like

Does it have keyway? Just grub screws? Sounds like a loose axle to me

1 Like

Id say so too, as though the axle is slipping in the can

Could be, but on the video it doesn’t look like this as for me. He can just hold the bell with his hand.

1 Like

I agree. He stops the motor. I just mean the sound.

1 Like

So after digging through most of the board I noticed that one of the motors was running in sensorless mode, didn’t notice it when I was running the motor detection wizard yesterday, I guess I have to rip the whole motor out and fix the sensor or replace the sensor if I want it fixed ( or the whole motor, not sure ),
Im still learning and I didn’t know that I needed to set parameters on the vesc connected through can separately until yesterday
Heat sensor is all over the place, rocking from 7-55c° but the motors are cool to the touch so it must be bad reading
I kinda need the low speed power, wet snow is a pain to ride fast in
Can I set some parameters in sensorless to give me more low speed torque?
What do you guys recommend doing ?

here is another video

im getting some jerking in my board, i have no idea whats going on, both have newest vesc firmware(4.01), have identical settings, i tried setting T to 1000 us on both vesc’s but still jerks

1 Like

Downgrade to 3.62 and look if it’s getting better, maybe.


Do you get this fixed? I’m having the same problem.

I think so, I haven’t really ridden hard for some time, but I remember redoing the firmware upgrade and redoing all the settings again