I can't control the speed via the remote


I was hoping that my 1st message would be to share my build and my experience. But I need help :slight_smile:

The problem is that I can’t controll the speed via the Remote. Pushing a little bit the throttle goes directly to top speed.
I have tried many settings without success. I have used the SetUp motor wizard via the vesc tool. And then lower down those values:

  • Motor current max to 60A
  • Motor current max brake to 60A
  • Battery current max brake to 40A
  • Motor current max Regen to -20A
  • Battery Volatge cutoff start: 40.80v
  • Battery Volatge cutoff end: 36.00v

Here is my build:

ESC: FLIPSKY FSESC 6.6 with aluminum case

  • EPRM:150000
  • Voltage: 8V - 60V (Safe for 3S to 12S LiPo)
  • Voltage spikes may not exceed 60V
  • Current: Continuous 60A, instantaneous current 150A.

Motor: Single FLIPSKY 6374-190kv-3250w

  • Max Power: 3250 Watts
  • Max Current: 85 Amps
  • Number of pole: 14
  • Internal PCB with 120 Degree Hall Effect Sensors.

Batterie: 12s5p – 18650

  • Cell: samsung 30Q Lithium Ion
  • Built-in BESTECH BMS 80A Continous
  • Voltage: 43volts (645 Wh)
  • Autonomy: 15000 mah (50-60km)
  • Max current: 100A peak 75A continious
  • Charge voltage: 50.4V
  • Nominal voltage: 43.2V
  • Cutoff voltage: 36V

Remote: FLIPSKY Screen Remote VX2
Wheel: 97mn
Rider profile: I am more interrested by the range and to climb hill than the top speed.

This is frustrating as this board already cost me so much.
I would really appreciate any help.

By the way, this is my 1st message and 1st build. Also I am not a native english spoken.
So sorry if I do/write anything wrong…

1 Like

Do input wizard and make sure the throttle responds as it should in the live plot.
If it looks good, change ramping

1 Like

Were you testing with the board upside-down, with no load, or did you test standing on it and riding? Because without any load the motors usually only need a sliver of current to start turning and reach max speed quite fast.


Thank you for putting so much effort into your post. Such a breath of fresh air

1 Like

1st at all. Thanks for your answer. That’s nice.

Yes I have tested upside down.

I have seen same response to another similar issue 2 weeks ago (can’t remember where).
But what I don’t understand is that i am able to control speed with the yuneed ego-2 with the board upside-down.

Could it be because my DIY board is more powerfull ?

I am scary to test and to have accident. It seems so much more powerful than the ego-2.
And because the coronavirus. I can’t move outside…

Thanks to you also for your fast answer.

I am using the plot COMM. THe input wizard seemd to work only for PPM remote.
I can’t set the remote via the ves tool. Maybe i do something wrong. I have understood that all the settings has to be done via the screen remote fot The Flipsky Vx2.

FOC BLDC standing on the board (loaded) or free running upside down?

If it’s FOC upside down the very little force will hit max speed very quickly hence why small throttle will hit max speed


Was beaten to it

That’s just how their ESCs work. On vesc based ESCs, current mode (which is what most use) will apply a constant torque to the motors, without any speed limiting, so when it’s upside down, it’s perfectly normal that the motors spin up fast. You can just place your board on the ground, and that will be enough for you to see that it doesn’t actually go full speed that fast when in use.

If you’re worried, you can place it against a couch or something so that you don’t damage anything :smiley:

1 Like

Was long time since I setup anything besides the wand, but you can plot it in the app settings if you choose the right input in the general APP tab.

What I meant with the mapping part was that if you do half throttle, the mapping response should be about 50% ;

If that seems correct then its probably the fact that its unloaded that makes the board go ape, like the boys pointed out :point_up_2:

Free running upside down. And FOC as I have used the SetUp Motors FOC wizard.

So if i understand correclty the different answers. I need to try the board with my 86kg :-).
I will try in a few hours and let you know tomorrow. Thanks to all

1 Like

Yep but carefully could be fine gets quite a few people the first time.

other thing most likely is did you run the input setup wizard correctly can’t rember if you remote is PPM based or Nrf. If it’s ppm could be pules length end/start as @linsus saying

Not even, just its weight alone is enough to check that it responds correctly.

1 Like

Thanks for your answer. I can’t see anything moving neither in Vesc Remote neither in PPM. This evening I will try with the board in my flat :slight_smile:

Need to select this part right for anything to show. (dont forget to apply settings)

Thanks. That’s nice.

Because I can’t go out, I could have tested only on 6-7 meters.

But it was enough to have the feeling that you and Darkie02 are totally right.
Thanks a lot to everyone for your fast answers and above all for your clear explanation.


I confirm.

I think the problem is solve. But big thanks to have taken the time to post this screenshot.
I really appreciate it.

I have already tried this also. But was not able to see anything moving in the vesc tool.
It is like i cannot set anything via the vesc tool for this remote. Maybe my bad…

Note we can set a few settings via the remote screen (i.e: cells, wheel/motor pulley…)

For information. The cable that I have received with the remote was not a cable that can be attached to the PPM connector. And it was most probably a cable for the FESC 4.4. So I had to invert 2 the TX and RX wires. Here is how I have attached the receiver to the FESC 6.6: