Help with 2x dual esc setup

So I’m doing my best to figure this out as I go but I’m getting stuck on this step with my frist build.

I have two dual ESCs, spintend ubox, connected as shown in my diagram. I jave been succcesful in running motor detection for the ESC connected to the remote but not for the other. After I setup both ubox’s (four sets of esc settings) via andoird phone/bluetooth app, I find inconsistent results with motor setup.

My last attemp left me with the remote ubox reaponding/spinning two motors, but the other only spins 1 motor. This is when I use the spintend remote accelerate input.

The non-remote connected ubox is throwing -11 motor detection error sometimes when running motor detection.

Is my attempt at connecting everything wrong? Is there a process I should follow for setting up 4 motors, canbus, two uboxes?

which fw?

on 5.2, there’s a bug where the tool reads the second dual esc as a single
i got around it by disconnecting the can and configuring each esc on their own, then reconnecting can, and then setting up input

2 Likes

One ubox has the micro USB and the other has the TypeC USB. The spintend product page has two different files depending on this difference but they both say 5.2 on their site. I’ll confirm what my app tells me and see if I can get your suggestion to work.

1 Like

the different ports should be fine long as you got the cables

you’re gonna need to unplug from one esc to plug in the other anyways since we’re gonna treat each on as if they were 2 different boards so to speak for config

set up the currents and all that motor setting stuff as you’d like individually, then you can connect both sides and set your input/app settings to however you need, good to go after that

I finished setup for one ubox with sensors and connected to remote. I disconnected the external CAN and did it through the phone app. Two motors spinning nsync. Movi g on to the next ubox now.

2nd typc usb ubox finished motor detection and I changed the settings for both ESCs via phone app. Going to reconnect the external CAN cable andd see what happens.


That worked. Aside from the cogging of the sensorless TB6380s upfront from a stand still start, all four motors and spinning fine and reacting to my remote throttle.

Thank you, @poastoast

2 Likes

Did you try hfi for the front motors?

:smiling_face_with_three_hearts:

also, ya, it may be worth a short to play with hfi (though it’ll take a good bit of tuning, but at the same time the sensored motors will “hide” any picky issues)

1 Like

I managed to setup HFI for the front motors. I followed the common youtube tutorial everyone references with the guy setting up raptor hub motors.

I had the TB6380s and the FS6384s all working together with the UNI remote for a could tests but now I have another problem.

The internal CAN connection on type Type C Ubox is no longer working. Motor detection wizard only finds one motor. I can successfully detect a motor on ESCa and ESCb by running through the wizard individually for each side.

I tried:

  • toggling the CAN communication on/off by pressing the power button 6x/7x.
  • connecting a CAN wire from ESCa to ESCb (CANH&CANL wires).
  • upload the FW on both ESC a and b.

This did not work.

Is there something in the VESC tool I can try to troubleshoot or reset the connection? Can I visually identify an issue on the PCB?

I had an issue similar to this where for some reason, both sides of the ESC ended up with the same CAN ID. Check that by plugging ESC in via USB and comparing.

on fw5.2 there’s an Id issue, where one of the dual escs is identified as only one esc

Have you tried disecconecting the can cable then individually setting up the escs by themselves completey, then connecting tthe can cable and setting up input?

Is CAN ID different than this VESC ID in App config?

Nope, that’s the setting I’m referring to

So the #7 CAN light on m USB ubox will not turn on/off. I don’t know what’s going on.

Ssooooooo this works:

Butttt this does not work: