Help! USB C port fell off of my unity

The title pretty much says it all. I opened my board up to do some maintenance and I see the port loose and completely disconnected. I know I can get it fixed but what can I do in the meantime to program it? My motors don’t like to calibrate via the app, it usually takes a PC to get them working. This has been my experience ever since switching to 6374’s. My board runs right now but needs a firmware update (metr pro lockup issue) which I know will wipe the calibration. I’ve heard that you can connect a unity to a PC via Bluetooth; is this recommended ? Any help is appreciated guys!


If you have a BLE module or the Metr Pro, you can definitely program it using your phone or PC.

If you’re comfortable with your soldering skills, you can solder it yourself or ask around whoever’s in your area to see if they can do it.

1 Like

I’ll try programming via the metr pro app tonight. Fingers crossed!

I can do the soldering myself but I rather wait until after the DC Invasion ride coming up.

I never used the usb on the Unity. Just go through the app. For more advance setting you need a metr to have a TCP conection but you will probably be fine with the unity app alone.


Every time I use the unity app to program the board it doesnt pickup the motor sensor values, only when running the PC version does it work. Then again, the newer firmware may have fixed this. Thanks for the input im gonna give the unity app another shot.

do you hand spin the motors as requested? A really good fast hand spin :blush:
For the unity pc you need the custom focbox tool and not the standard one.

1 Like

Yes I do hand spin them, I strap my board down and use one hand per motor trying to get as much spin as possible.

1 Like

no need all that power I do it on the elevator some times :laughing:
Weird that you can not detect it like that. ON the PC you can set higher current for motor detection but if that one works on unity app then sensors detection should be independent.

1 Like

I use the one from the Unity product page. This is what you mean right?

yes correct.

1 Like

Oh I haven’t tried that trick yet, definitely gonna up the detection current. Thanks!

that on PC only. You can also increase duty.

Anyhow metr TCP connection requires the PC and phone to be on the same wifi. If that doesn’t work then use phone mobile data and hotspot for PC.

This is all new info to me, glad you told me. Once I get to the shop I’ll be updating this thread with how everything worked out using your steps. You’ve been a huge help and fast too!


My pleasure. TCP connection is great, but it requires some extra steps. You find the TCP connection in the Focbox tool under Connection --> TCP and you have to copy what you see on the metr TCP window. Basically the IP and port numbers, then click connect. For the rest is a normal VESC Tool.

Super cool, had no idea this was possible

1 Like

This just happened to @Itsmedant too. And I remember someone else recently…

Yea, I was able to connect to the unity tool over the TCP option with my metr and set up my new OSRR on the board.

Only problem, if your phone goes into standby, you drop your connection. There is an option in the metr app to make sure they phone does not go into standby while you are working.

Let me know if you can’t get it, I can try and walk you through what I had to do

1 Like

Thanks! I definitely will be.

1 Like

@Deodand @JohnnyMeduse Happen to know the part # for the usb-c on the unity?