Having trouble with UART pairing

I am having some issues pairing my remote through uart. I have a stormcore 60d+ and a Flipsky vx4. I paired the remote and receiver and they connect just fine, but I am having trouble with setting it up with the input setup.

I set app to use as uart
I set control to current
I set smart reverse to off
Motor configs are done

I really don’t know what to do for this as I have only used ppm before. If anybody has any solutions, please help. Anything is appreciated.

Have you tried swapping your rx/tx pins?

Not yet, but I’ll try that now

1 Like

It didn’t work

Try flippin to nrf

Do you have it set to Fsesc 6.6 in the vx4 menu? Also is your control type set?

Control type as in uart/ppm/nrf?

His talking about the menu on the remote

Then uart

I’m having the same issue. Just with a new bkb voyager remote. Stormcore 60D.

Uart/current is selected.

I get board voltage in the display. So there is some communication.

Everything worked with the ppm remote i used before. Still does when choosing ppm as control and using maytech remote it had before.

So, bumping this thread hoping someone has the golden answer.

1 Like

Check the VESC remote tab.

It’s set to current, smart reverse is off also

1 Like


This was the trick for me. It’s now rolling. Thx @glyphiks

Did you have any luck @Akbrock47 ?


I checked them but they did not need switching

It just randomly started working for some reason though even though I didn’t do anything


“VX4” + “Stormcore 60d+” here.

I had the same issue.

After flipping the TX RX pins as suggested by @glyphiks everything works now.

Settings on Remote:

  • ESC Type: FSESC
  • Control Type: UART

Settings in Vesc:

  • App to use: UART
  • Control Type: Current