FSESC 6.6 DUAL repair

I killed master side (left side on photos) of one of my five FSESC 6.6 DUAL, shorting some sensor cable with red phase wire.

Blue light OK but no green light

I can’t see any burnt chip.

Is there any simple way to find out what is wrong? Anyone could test and repair it?

Canada - @JohnnyMeduse

USA - @ThermalM16

EU (I think?) - @seaborder

Australia - @elitejarcool


LOL :joy:


France, pm me


@elitejarcool does em,


Thanks, edited :slight_smile:


I tried to replace STM32F405RGT6. First time, using CHIPQUIK. Not easy! I think I succeeded. But it doesn’t work anyway… This was obviously not the dead chipset…

1 Like

I’ve understood I have to flash the chipset with STLinkV2.

I tried the black magic method with working slave side, soldering IO, GND and CLK together, but it doesn’t work (“can not connect to target”) as for many people…

Maybe cables are too long. @Trampa says 8 cm max.

Next step : ordering STLinkV2.

1 Like

The cable length is not the issue. Probably something is damaged on the other side. It should connect.


On dead side I have blue light but not green light, I have 5V but not 3V.

With this specific ESC I saw on another forum that someone succeeded in connecting working half with dead half with black magic connecting 3V together too (aside IO, GND and CLK). @Trampa is it risky attempting that?

No 3V means the voltage regulator is fried. Only a repair helps.

1 Like

Success!!! :partying_face:

I had to replace STM32F405RGT6 once more because at first I killed the chipset by shorting SWCLK and GROUND while programming chipset because of hazardous temporary cable soldering. Then I secured everything with hotglue.


Finaly I tried to use this repaired ESC but experienced some issues :

Both side of this dual ESC are working BUT :

  • USB port seems to be dead on master side (where STM got replaced). It doesn’t want to connect. I can connect with METR PRO on UART through TCP and I can also use CAN. USB is OK on slave side.

  • I can not downgrade firmwares. FW 5.1 (VESC-tool 2.05) is now installed on both sides. I’d like to install ACKMANIAC firmware. I upgrade firmware on both sides. It says they get uploaded, but FW remains the same (5.1). I also tried to upload bootloarders but it was worse because I couldn’t even connect to the ESCs by any way.

Then I had to use STLINK on both sides to reverse this mistake.

Now FW 5.1 works on both sides. I could run detection and the ESC works normally.

But how can I downgrade to ACKMANIAC!? Watt control is god to me. :wink:

I read this tutorial https://boundmotor.com/downgrade-vesc-firmware/, but I think that’s the way I bricked the ESC at first time (by uploading bootloader eventhough a bootloader is already installed).

OK I managed to downgrade from FW5.1 to ACKMANIAC FW.

Here’s the way to do it, with bricked DUAL (V)ESC :

  • Upload latest FW (5.1 nowadays) (https://github.com/vedderb/vesc_tool/tree/master/res/firmwares) to both STM with ST-LINK utility.
  • With vesc_tool_2.5 : Firmware >> Bootloader >> “(upload) All” button.
  • Write motor configuration, then Write app configuration, then Disconnect.
  • With ACKMANIAC-ESC-TOOL : upload firmware to each (V)ESC.

You’re done! :partying_face:

Official FW is not bad, ACKMANIAC is just better IMHO!!!

I didn’t get to recover USB port on repaired ESC side. It seems dead. I really wonder why…


Mind sharing link to the STM32F405RGT6 Chipquik

Good repair I have fixed mine it was a leap of faith but STM is easier than the driver.


SMD1 - Kit de retrait CMS