Flipsky VX4 remote

I think 2.5, I forgot. Bought it from someone else


I switched my VX4 receiver from uart to ppm on my Unity because I added a Davega, and now I can’t get it to trun off. If I unplug my receiver from the ppm port, I can turn it off. Any idea how to fix this?


1 Like

Okay so I have a vx4 but the potentiometer went out in it. I love the remote but I don’t wanna buy another one so I was wondering if anybody knew what kind of potentiometer was in it and where I could get one.


I’ve been using my puck in lefthand mode in my right hand like you advised and it works like I wanted it to. Thank you for that.

1 Like

I also have a vx4 with a janky potentiometer.

This guy has replaced his with a better one:
@3DServisas is that you?

Plus @ShutterShock said he was going to replace his pt with a Cybersomething pot that is better.
Shutter: how is that coming along? I need videos!

Here another one with a janky potentiometer.

edit 1

I found this on Facebook for a new upgrade 1.2

"Dear, sir. We sincerely appreciate your message and your interest in our products.
The 7 key points of new features from Flipsky Remote Controller VX4_1.2 are followed:

  1. Home Screen Switching
  2. The Channel Hopping Function
  3. Remote Throttle Joystick DeadBand (I have this problem)
  4. Low Battery Warning
  5. Motor Rotation Forward and Reverse
  6. Throttle Gear Lock
  7. Remote VX4 Receiver Upgrade.

More details will be posted in our official blog this week… "

edit 2


@PedroMcJimenez Replaced his VX4s pot with a Cybertech Throttle. Cant find a piture right now though.

I installed the v1.2 firmware and works for me. No deadband now.
I followed this tutorial:


I also updated my VX4 firmware and I like the new main display and all the added features. Still zero issues with mine.


Too bad no files to be able to update via Mac.

I sent something to Flipsky about that. When I tried to download the files on a PC laptop the files are corrupted.

1 Like

Tried downloading the necessary update files to my work PC to update the remote but it seems most of the files are blocked by my company’s antivirus stuff. Anyone know if it’s possible to update the remote on a Chromebook? About the only hope I have left is my 11 year old son’s Chromebook. jeez.

1 Like

Any chance it’s just a Windows error that you can get around? These error messages can be skipped if you click the little more info text

Apologies if this is basic stuff you’ve tried already, VESC tool popped one of these for me last night so it’s fresh in mind

My work computer is too locked down with antivirus/defender type bullshit, I’m not surprised I couldn’t do it on it. I don’t even know if I can install a font without IT admin rights. I didn’t realize there was an .exe file as part of the install process as well, which is definitely blocked from install on my work comp. My only hope is my son’s Chromebook


I’m having a hard time updating to 1.2
When I updae the remote to 1.2 , the receiver is not recognized therefore I can’t update It
Can’t even pair the remote anymore
I reverted to 1.1 and everything is fine
Should I update the receiver before the remote ?

1 Like

First you update the remote .
The receiver must be switched off. After updating the remote, go to the IAP Receiver menu and press start. Then turn on the receiver, the red LED lights up and start updating V1_2_VX4_RX_Bootloader_Update_APP.bin and then V1_2_VX4_RX_APP.bin


That’s the only thing I’m not sure I did, how do you do that?

‘‘IAP receiver’’ click menu button

1 Like

I’ll try, but I think I did that