Flipsky VX2 Backwards/Forwards issues

Hey, all.

I’m going to try to explain this as clearly as I possibly can. I’m replacing a VX2 remote with a new VX2 remote (Torque6 esc’s), and I’m having the weirdest issues. It all depends on which order I turn the board on and the remote on to connect.

If I turn on the remote first and then the board, the board responds to forward throttle and reverse as it should. Real-time telemetry is accurate.

If I turn on the board first and then the remote second, the board responds to signal the exact opposite. Board moves full power in reverse when I press the throttle forward, and when I press the throttle forward, the board operates in smart reverse. When I do this, I have to go in the vesc tool app and reverse the motor directions, but the real-time telemetry is still mirrored backwards on the VESC tool app (negative MPH, negative duty.)

Aside from making sure I do the first paragraph’s process, what is the deal here? I never had that problem with my previous VX2 remote. Only reason that I’m replacing it was that I took a hard fall, and I pieced all the pieces back together, but the power button broke. Not the operable switch (that’s fine), it’s just exposed to the elements.


There is a button combination that you can activate on the remote that reverses the motor direction, have you tried that?

1 Like

I didn’t know such a thing existed, what is that? But that still doesn’t explain why it operates like it does with mirrored telemetry etc. just by the order that one device is turned on and connected.

I don’t really know why it’s doing that either. And I can’t remember what the combo is, I think its throttle to full brake and then press the power button.

What setting do you have it for connecting to the vesc?

FSESC, I’m using dual Torque6 ESC’s

Hm… I don’t remember what option I selected on my friends board

One option threw a ton of errors and the other one worked fine

It would be this or FOCBOX, and I’m definitely not using FOCBOX.

I mean I don’t really know what changes when you switch those settings. I’m not super experienced with the Vx2

Have you walked through the official setup video to make sure everything is as it should be?

It’s a good place to start.

The reverse instructions are at 2:52 - https://youtu.be/GoPVR6vJFcs?t=172

1 Like

I’ll give it a shot. Curious if anyone knows why it behaves the way it has been. I’m using UART, haven’t adjusted anything else. My app settings reflect that as well.

Unpairing and re-pairing might fix your issue as well. Ye old turn-off, turn-on IT guidelines step 1


That fixed it a time before, but the issue prevailed. Wonder if it’s a remote issue, like the remote itself? I could always return via amazon prime and request a replacement :man_shrugging:

Did you ever get to the bottom of this? I have the exact same thing, running the VX2 pro on the Flipsky fsesc 6.6 dual and if I power on the esc before the remote it will always be backwards… turn the esc off and then back on again and it’s fine or like you indicated, have the remote on before turning it on and it’s fine. Seems like maybe a firmware issue? The switch direction instructions in that video is great as couldn’t find that in any of their guides or faq’s

I had this exact problem just the other day. I went into VESC settings and reversed the motors and works well now.

I worked it out. FW and RW on the remote is the direction it’s been configured in, however the esc is super helpful at figuring it out itself. So if your remote is in RW and you switch on your esc before your remote, the esc figured the direction before knowing the remote setup.
With the board off, you push the throttle to full then into reverse and double click the setting button to switch into FW. After doing that the problem has gone.
Ps. FW is forward and RW is reverse… Flipsky logic


Hi there, I have the exact same issue. I tried following your instructions; however, I don’t know what you mean by ‘double click the setting button to switch into FW’. Could you explain, please? Thank you.

1 Like

Here you go, skip to 2:55 on the vid - Electric skateboard remote VX2 Pro tutorial | Flipsky - YouTube


Thank you very much. That worked!

1 Like