Flipsky Dual VESC will not auto-connect

Link to my speed controller:

I have tried everything suggested in the forums that I could find. I am using a data USB cable and the VESC tool. When I click auto-connect, I get “Serial port error: the system could not find the files specified”. I have attempted to update my drivers, but it says they are already up to date. There is a yellow triangle under that driver as well. Does anyone have any advice?


hey bud sorry this isn’t working as easily as it should. it sounds like a windows driver issue, if there’s a yellow triangle in the system devices window.

sorry i’m not of much help, im not a windows person

1 Like

Does anyone have a link or a walk-through on how to update / fix the drivers. I have found a few links that say they update and fix the yellow triangle bug, but they no longer function, (the link leads to an error 404 page not found).

Zadig usually fixes my driver issues


Google it

There’s two places in the vesc tool where you can ‘connect’ to the vesc, try both. I remember when I had a Flipsky only one would work

Win 7?

Win 10. And yes, I have tried both micro usb ports on the VESC. Sorry about the late response, the lock-down here from the corona virus has been taking priority.

After downloading zadig and selecting list all devices, I do not see that anything is connected besides my keyboard and mouse. When unplugging my keyboard and plugging in the VESC usb wire, zadig does not see it, but continues to see the mouse is plugged in. I’m thoroughly confused. Does anyone have any other ideas?

Is the vesc new or new to you? If new to you, you may have no bootloader on it. Just a guess.

In the vesc tool there should be two different buttons labeled auto-connect… The one on the welcome page and the one in the connection page.
Make sure you try both.

Alright, I tried a different computer and ran through all the setup steps again. The vesc will connect on USB 2 port, but only one of the two motors spin. It will run motor detection and complete the setup, but only on one motor.

I still cannot seem to get USB port 1 on the vesc to connect. I assume that is the master side?