Flipsky Dual 6.6 Can Bus not working PLEASE HELP!

Hi Guys, its been a while. I recently purchased the Flipsky Dual 6.6. I plugged everything in, then downloaded the most recent version of the vesc tool. I then proceeded to perform the motor detection. Before turning anything on, made sure the Can Bus switch was set to the “on” position. When I performed the motor detection, using the “all” button, only 1 motor spun up. I then decided to do a motor detection on just the slave “no. 2” side, and the motor detection was successful there as well. I then went back to the master side and once again tried to perform motor detection for both motors and only the Master will spin up. I have 2 blue lights and 2 green lights lighting up. I have updated the firmware on both sides of the Vesc and still only get one motor at a time to spin up. Do you guys have any idea why this brand new ESC isn’t working? Did I miss something in the setup? Any advice would be very helpful. Any specific tests I can or should perform? Thanks in advance guys. PLEASE HELP!

3 Likes

This won’t be helpful but “welcome to Flipsky”

6 Likes

You could try to run a condinuity test on the under side of the switch. I dont know off hand what pins to use, but for example…

Use a multimeter set on resistance mode. At first it should read out something like infinity(it will do something to show you infinity, one just says “0…”). If you touch the two prongs together you should see real numbers appear.

Go on the underside of the board, which may require unscrewing the heatsink. touch two pins with your prongs and note if its infinity or a real number… then flip the switch and try again. As long as you are on the correct pins, there should be a difference when flipping the switch… If there isn’t, your switch could be bad or not properly soldered. In this case, definitely research which two pins should be connected when the switch is on, and then solder on a jumper wire to leave the switch forced on the whole time.

Thats by best guess if it has to do with the switch… Also I know there is a condinuity test option on some multimeters but mine does not have it, so I just use the ohm setting and it does the job with a bit more technicalities.

Lastly, If you are really in a pinch, check out my posts, I can always send you my Flipsky 6.6 dual which only has one functional side. You could run a CAN cable to it and have 2 functional vesc based chips out of 4 total chips haha.

1 Like

Try it also with off, just to be sure…

1 Like

Anybody out there? I need a solution or at least a reason. I sent the first controller back and purchased another one with the exact same problem. I’ve tried 2 different computers and the vesc mobile tool. I’ve downgraded and upgraded the firmware and the vesc tool version, and still cannot figure out why each side of the vesc works when plugged directly into each, but when I do the motor detection it only finds one motor. I’m completely confused. PLEASE HELP!

1 Like

Again, not going to be helpful, but if Flipsky will let you send it back again, do it and buy a makerX DV6 for the exact same price. Hopefully you’re able to sort this out!

1 Like

You do have CAN forwarding enabled in the VESC tool, right? This one right here:
image

1 Like

Yeah every time I push that it pops up an error saying that it can’t read the firmware. I’ve updated the firmware about a billion times.

1 Like

@Flasher it was recommended that I ask you here on this forum instead of the builders forum. Did you ever find a way to bridge the Can Bus switch? Or bypass it? On the flipsky dual 6.6? If you have any insight it would help tremendously.

Since you have managed to connect to each seperately, have you thought of assigning each their own identifiers (master vs slave) ?
For example, on mine, one side has ID 00 and the other has ID 01

Not assigning those could cause a conflict as the program doesn’t understand that they are 2 seperate entities

I didn’t try assigning them, but when I run the foc wizard it assigned each it’s own random Id numbers. Master is 80 and the slave is 46. You think I should try to change them to 00 and 01? I suppose it’s worth a shot.

Wouldn’t do harm but I don’t think that’ll do it. I’m trying to see in my mind what options you have.

Stupid question: your canbus switch is in the on position?

I’m about to go into lalaland so I’ll give a few pointers before I go.

Canbus switch to on?

Both sides motor detection function?
If yes, can forwarding set to active/true?
If no, all lights turn on for both sides of ESC?

There’s no way of bridging the 2 sides of the same dual unit as the canbus is hidden inside the pcb traces.
But if nothing works, there’s a good chance that you could reflash the whole unit with an stlink and have a perfectly functional ESC as a result. If needs be, there are multiple threads about reflashing firmware/bootloaders on here and the old forum (I’m in many of them) and a few of us know how to do this so don’t despair, you’ll be rolling soon

There’s also perhaps another way that I didn’t need to reach that would be connect receiver to both sides and treating them as seperate ESC units. @b264 would be your go to man at that point

1 Like

I have had a similar issue and solved it by programming each side separately

1 Like