Enertion Raptor 2 settings for Flipsky VX2

Hey guys, my Nano-X finally gave up and the 2 speed settings is such a big gap that I don’t like it anymore compared to my other DIY boards. It’s time I upgraded to the VX2 Pro remote but having a hard time finding settings such as POLE PAIRS? I ride with 97mm on the rears and front stock 90mm. Anyone have any idea what the POLE PAIRS are? I think by default it’s on 3. And can we use the BT module to change from PPM to UART? or does it need the cable? I hate hooking it up via USB really! Thanks in advance for all the assistance.

What motors are you using?

stock Raptor 2 motors. They are all black.

7 pairs/14 poles

2 Likes

pretty sure its 28 poles.

1 Like

thanks guys i will try the 7 pairs 1st. I have dual focboxes and what firmware should i be using on that list? this is taking more time than I thought! And i just found out that the enertion BT module doesn’t work with the android vesc tool so i had to change it out to the flipskys BT module. I will flash firmware with the PC app. I will keep you guys updated.

PS do i only have to change the setting from PPM to UART on the vesc tool?

1 Like

you will mess up your motors, old motors have 28 poles

410 411 412

I may be wrong about the poles and pairs. Do your homework or wait for more responses.

1 Like

No he will not. He’s calibrating his remote which asks for the motor poles/pairs so it can show the correct telemetry data.

2 Likes

Yeah +1 I came to say the same as X, the remote has no impact on the motors. The only data it sends to the ESC is throttle, and when it asks for tooth count, cell count, wheel size, and poles it’s just so that it can accurately onvert raw data from the ESC to rotations of the wheel and therefore speed

2 Likes

Thanks guys i think i sceewed up. VX2 is after thought now. I may have flashed the incorrect FW with “48”. I can no longer see the list of other firmwares. How do i get back?

Yikes! Help!

go into “included files” you seem to be in the bootloader tab?

1 Like

it’s actually empty under that first tab. Or it has 48 only. It’s not bricked (i think). Anywhere I can download the regular 4.1X FW?

Update: I got the 4.10/11/12 firmware loaded (i picked the default.bin instead of the other 2) onto both FOCBOX VescX. Got the remote to work. Everything looks like it is working EXCEPT for the odometer and speedometer on the Flipsky VX2 Pro. Any suggestions? I tried the different POLE PAIRS but doesn’t look like it makes any differences.

Updated 2: I got the VX2 Pro to work, it took some time playing around. First the throttle and brake felt fine. Played with all the numbers on POLE PAIRS and still to no avail. Then i scrolled through the VX2 menu and, what the hell i gave it a shot from FOCBOX to FSESC, BANG! everything worked. Set the Pole Pairs to 14 and seems to be OK since I can see the board’s battery/current/MPH moving. I’ve only bench tested it since it’s too cold outside. It went up to 36mph with 97mm PUs. The higher the Pole Pairs, the slower the speedometer. Thanks to everyone that assisted. Hope this can help others as well!