DAVEGA X Updates

I’m not seeing any lights on the BMS when I turn the unity switch on…


Connected the opto enable. Works now. Thanks!

2 Likes

Hm, weird. I don’t think that’s necessary. @SimosMCmuffin, can we please have your input?

I gotta say it was in fact necessary in this case. I thought it was not. That’s why I did not connect it to begin with. I’m not very good with electronics. All I know is connecting the opto enable solved the issue. I saw a pack badly out of balance, so I’ve now set the Flexi to always balance to correct this pack.

FlexiBMS lite is now available to purchase in the DAVEGA e-shop so you can grab one along with a DAVEGA X and save a little bit on the shipping. This may be especially relevant for overseas folk.

The price is slightly higher than in Simo’s e-shop so you if you want the Flexi alone it makes a whole lot more sense to buy from Simo directly.

6 Likes

What happens over 10A charge? Bms throttles? Something burns? Need additional cooling?

There’s no throttling. (I don’t believe any BMS actually does that.)

Simo has done some thermal tests.

2 Likes

The xiaoxiang smart bms can throttle or cut off charge from the app, but the app is hot garbage in the first place unfortunately.
Have you got a pic of the hot part front and back? Tempted to see if a bar of aluminium with thermal pads can fit on there

1 Like

You mean it can cut the charge if the current is over the configured limit. It can’t throttle/restrict the current though. Or have I missed something?

1 Like

I tried it now, it just shuts off. Fake news from me

2 Likes

Taking measures after a recent incident…

27 Likes

Did you put it in on both sides? Just to be sure :cowboy_hat_face:

6 Likes

And on the main box each on every side. Maybe the welcoming screen on the unit at first boot as well.
Can never be too prepared

2 Likes

I wouldn’t be surprised if that was going to be my next iteration. :sweat_smile:

10 Likes

19 posts were merged into an existing topic: Public chat - talk about everything with everyone

This is so fucking awesome @janpom brilliant :love_you_gesture:

PS: Fixed :stuck_out_tongue:

3 Likes

Nice! You may also want to upgrade to version 4. Upgrade to v4.00 - DAVEGA

BTW, wrong tag. :wink:

2 Likes

Also, the RC releases may be unstable. If you want to test them and come back with a bug report if something is not working, that’s highly appreciated. If you prefer not to be a guinea pig though, then stick with standard releases.

(RC = release candidate)

2 Likes

Yeah many thanks, I just installed the Davega and I wanted to try the update-over-the-air feature :smiley: will update it to v4 before I go riding this afternoon! :love_you_gesture:

1 Like