Choppy signal Puck Remote

Something strange is happening with my deck recently. During first minute of the ride when I apply throttle signal is choppy. There is acceleration I’m losing it for brief moment, that causes a kickback that might throw you out of the board if you ride high speed and the acceleration continue.

Issue is very strange. Started 3 rides before and only happens during first minute(s) when I turn the board ON. Once it ‘settles’ all is fine and I cannot trigger it.

I don’t think that is physical damage. I tried to trigger it by aggressive carving etc. and nothing. I also disassembled the board and everything is ok. What I think might be happening is receiver/transmitter losing packets due to channel hopping which is implemented in Puck ?

Any ideas what might be wrong or how to pinpoint the issue ? My HW: DV6 Pro + Puck Remote

1 Like

Have you checked the signal response in the vesc tool? Is it jumping around etc?

Pictures of the inside of your board + how you have the receiver connected would be helpful, otherwise we just have to take your word for it

Can you reproduce the issue reliably? Is it always in the same area? Does restarting the board cause it to happen again?


Did you get the email from Hoyt a few months ago about fixing a potential issue with the potentiometer and/or follow their suggestion?

“Near startup only” faults sound like a temperature dependent issue, more experienced people than me explain that a marginally working solder join can half repair itself once it warms up a bit. I’m deliberately not using the word reflow because it’s really more temporary and weak than that. It varies a lot but another mechanism is thermal stresses (either the part warms up and causes a slight bend and adds stress, or bends the other way and eases up), but the end result is similar: No Fault Found intermittent wonkiness. I had this with a GPU where the BGA soldering would glitch itself out once the board came up to temperature, not enough to hard crash just to introduce a shitload of memory bugs that cause visual artifacting

@xsynatic I can only do that when the board is disassembled. I don’t have any BT module in it. It’s gonna be hard to do because the issue lasts sometimes 100m sometimes more.

@rusins I’ll post pictures soon. I don’t think it is related to my area. Other boards does not have that issue and on the way back all is fine. I think I can reproduce it ‘kind of reliably’ sometimes it last only moment sometimes longer. I need to do more testing tomorrow if restarting repeats the issue. I know that turning remote off/on when the board is on does not repeat it.

@mr.shiteside About the solder joins ? When I got this msg first thing I did I put fresh solder joins so I don’t think that’s it.


ah cool, might be a red herring then. Was the fault close to the time you made the repair, or took a hard fall, or anything else like getting the remote wet? Just trying to spitball causes not blame you for it or anything

I tried to reproduce it today in the same area and no luck :joy: so It seems I cannot reliably reproduce it.

No crashed or other incidents this year so that’s not it. Nothing has been done to the board when the issue started occurring. It started happening after my long ride 30km but everything was completely fine.

I’m not sure but maybe it is related to standby time ? It seems that it’s happening only when I take it for a ride after few days of standby mode after charging. ( just a theory I’m not sure )

Here is photo of the board:

I wonder if a crimp has a loose connection / that black adapter from the white black red to yellow black red is loose. And then the enclosure heating up from riding might cause some thermal expansion to make a good connection. :woman_shrugging:

1 Like

do you have access to another remote and another receiver? It would be interesting to temporarily swap each and see if it changes anything.

1 Like
1 Like

@rusins This is normal RC servo cable in 3d printed enclosure glued to another 3d printed enclosure to keep cables organized. You can see silicon around that area because I damaged one pin but I patched it really well I double checked it now, wobble it while accelerating and it’s solid.

@DougM I don’t have unfortunately. I might buy vx4 to test it but I heard about some issues.

@Zachsnotboard I might do that to my remote. I got scared when he started talking about full throttle.

Posting, because I finally managed to resolve the issue. Let me describe exactly what was happening for future users that will find this topic.

Like I wrote previously It felt like I was losing signal in my first 5 min of the ride but recently I had new issue. When I tried to break, board would remain in keep breaking mode when remote was in position 0. You would try move the board manually back and forward and you could feel strong breaks. It would reset itself immediately when you give it throttle.

I disassembled the board, calibrated remote again and during calibration I tried to reproduce the issue and I did. I could see remote sending break signal in vesc app without applying throttle. I tried to shake remote and it unstuck itself. at this point it was obvious that Potentiometer was busted (It was soldered correctly, I made sure of that).

I ordered this one: Replaced it and it work as new.