Bricked 2 OG Focboxs Updating To FW4.1

@Trampa please explain

I’ve got 2 focboxs in my build. I’ve Flashed the new 4.1Fw onto the focboxs. Everything is successful, I wait 30 seconds, turn off the esc, turn it on and try to reconnect to my esc. It worked fine for the first 2 focboxs. (could read and write data etc fine)

after that i reconnected to setup my DieBieMS CAN settings. no worries

I then needed to change remote settings. So, i reconnected to the vesc tool, and changed the remote settings, properly disconnected etc. Then the issues began. The motor on one vesc began to stutter, the metr I had connected was showing the motor drawing current even though it was just growling (at the start it worked just fine). Then I’ve gone to reconnect to the focbox and tried to connect (with the same laptop and cable that definitely does read data) and the connection says either “failed to connect, make sure your vesc is connected and powered” or whatever or mainly “invalid serial port.”

So, i grabbed another focbox I had, connected it all up, could read and write on it fine. as Im running canbus i Flashed the new fw4.1 onto the focbox, waited 30 seconds, and went to reconnect and I’m getting “invalid serial port” again. one tried to connect to “invalid serial port” error on 3 laptops and it doesn’t work.

I heard that the vesc tool has this vesc rescue over can but there are no instructions that i can see?

what can i do about this? I’m pretty triggered atm

thanks for your help


… and no there are no fault leds flashing upon startup :slight_smile:

1 Like

On Linux I often have to reconnect my ESCs / restart vesc tool a few times for it to connect. Hopefully you just have the same issue, and not something worse.

Or if you have v1.6 Focboxes then maybe your CAN bus chips died. :man_shrugging:

If you have multiple COM ports, a lot of times it auto-assigns the wrong com port. You should check in device manager which COM pops up when you connect the vesc.
(My computer -> Rightclick -> properties -> device manager in the left column. Ports (COM & LPT)

You can SWD Prog it, but Focboxes do not have a SWD port. You would need to open the device, locate the port on the PCB, insert a JST connector or solder cables.

Minute 5:34 onwards

1 Like

When you used CAN, did you power up both ESCs simultaneously? Did you only connect CAN H and CAN L?

I’ll try this one now. @trampa yep, it was literally after the FW update, i went to reconnect and it said invalid serial, without changing anything

@Trampa no dice. I’ve uploaded the fw through swd and the focbox still isn’t connectable. What other options do i have?

I’ve also tried to install older fw that i know works and I’m still not getting it

Is this an issue with using CAN? I have an OG FOCBOX that I want to update but now I’m not so sure.

1 Like

i think it may be that each focbox was updated individually while connected in can. not sure if that’s really the case but ya

1 Like

If you flash via SWD, make sure to hit the disconnect button after the upload. Make sure you used the 410;411 412 FW.
If it’s not working after that procedure, there is a HW defect. These ESCs need to power on simultaneously when interconnected via CAN. otherwise the CAN chip will fry.

1 Like