Analog Throttle/Brake -- ADC2 does NOT cut power to the throttle? What is wrong?

Hi everyone,

I’m using an Analog Throttle/Brake for an electric scooter that I am using VESC on. The problem is that – ADC2 does NOT cut power to the throttle (ADC1 is hooked up to the signal wire of the throttle, ADC 2 is hooked up to the signal wire of the brake). If I hold BOTH the throttle and the brake, the motor still runs at full speed. What am I doing wrong? I did the calibration and have ADC1 voltage set to min 0.83v, max 3.3v, center voltage 2v. and ADC2 is set at 0.85v, 3.30v max.

The brake signal is definitely working as I have a brake light attached to it that turns on when i hold the analog brake. Why won’t ADC2 cut the throttle from ADC1?

I’m using the control setting Current No Reverse Brake ADC2

I had a similar problem, I think the vesc tool is loosing the setting from the assistant. On the last screen you have to select the mode again and then it worked for me :slightly_smiling_face:

Didn’t work…even after the wizard I have it set manually and ADC2 brake still won’t cut the motor.

Hmm, I’m traveling at the moment, otherwise I could look it up in my settings… You might try to run the assistant and when totally finished change settings in vesc tool. My problem was Exactly the same. I modified a kickboard for my gf and at first got the same results as you.

Yea that’s what I tried to do – I used the wizard and then applied the config. And then I went into the tool, under the section (ADC), and then confirmed the settings were on Current No Reverse Braking ADC2. Don’t know what I’m doing wrong… :frowning:

Can you take a screenshot of your settings and how it looks on your VESC tool?

I’m not sure if the braking (as in it turning off the motor) is working at all, even at half or quarter throttle, the motor spins very strong even with the brake pulled at the same time. The signal is definitely working – brake light hooked up to the signal wire which also connects to the ADC2 lights up when the brake handle is pulled, and the voltage spikes to 2.35v when i press the handle (real-time in the VESC tool app detects it), but the doesn’t seem to shut off the motor at all.

On the vesc if you use throttle and brake at the same time, the commanded motor output is throttle minus brake. Depending on how much throttle or brake you use this can be regen or drive.

I had issues with using ADC2 for brake on 4.12 hardware. Ended up soldering on a pull up resistor and inverting the logic in the VESC tool. Solved my problem