1st time vesc makerx dv6s

So I have my makerx dv6s plugged in on the local side and run motor detection. Should both motors run. I’m only getting my local side to spin and respond during forward and reverse even though both the local and can are both shown. Can does not respond. Ive tried running detection on the other side with the same result. Except it refers to the local side as “can”. I can only run detection on the local side.

Are you selecting the run detection over can button?

I remember there’s also app settings for what communication is sent over CAN. Which if left unchecked I think it would end up forwarding nothing…


Could be a bootloader/fw thing… Assuming this is new esc, did you update the fw before running detection? I wouldn’t expect you to have any problems with detection if you left it as-is, but if you updated fw. Make sure it’s makerx custom fw and reinstall the bootloader first then update the fw. Some people have better luck doing this separately for each side.

Yea. Run all motors over can. The cab side started to spin but then stopped. Now it dznt spin at all

I had a feeling I would have to try the bootloader thing. I’ll rewatch some bootloader YT vids. My very first DIY. I appreciate the help :pray:

1 Like

Bootloader is nothing special… Literally just go to the bootloader tab and update/reinstall the generic bootloader that’s already there.

1 Like

Flashed the bootloader still the same thing. So I flipped the motor cables and sensors on the esc and now only the can side is working but it’s plugged into the local side. . So I’m wondering if it could be the motor sensor on the esc?

Did you also flash the fw?

have you tried running detection without the sensors plugged in?

1 Like

A lot of times I’ve had only one motor want to go on my flipsky V6 and it has been from losing settings after saving a change without “read settings” first. I’ll probably get some reply’s to this about how I’m lucky to have even one motor going on the flipsky, but that’s not the point I’m trying to make.

A few times I’ve found both vescs had the same CAN address - so I just make sure they are both different. ie. 1 and 2, or 74 and 75 etc. as long as they are different.

Sometimes I have found that the CAN messages are disabled. I just enable all of them and good to go again.


m no expert, but worth checking those things.


That’s a huge help. That’s is ton. Unfortunately I accidentally knocked the cable out while it was detecting. Now it’s definitely bricked. Anyone know a good esc similar to the makerx dv6s that ships fast in the US. Trying to get it ready by April. Wrx with the v4 remote.

No. I only switched the sensors and it did the same thing just opposite wheel. I did manage to finally brick it. All part of the learning process. I hope to find an esc similar to the dv6s that ships fast in the US.

Pretty sure I ddnt flash the FW.

You wanna see if someone can get it working for you in the US? I have a knack for this kind of stuff, if you pay shipping both ways I can try getting it operational again


+1 for Evwan, he is a trusted member here. If your shit is bricked, send it his way


On a side note.
I am a fan of your Instagram

1 Like

I really appreciate that and would prob take ya up on it but I’m takin it with me to eskatecon. Mboards said they would fix it for me and send it back. I finally got it programmed with another makerx. Thnx again tho that’s cool as hell​:metal::call_me_hand::metal:

1 Like

:grin::sunglasses:. Thnx bro I really appreciate that. Really cool. Luckily I finally got it running. Still have a bunch to learn tho.

1 Like

:pray::pray:. Lookin back that actually sounds like it may have been it. I did a bunch of stuff out of order. Finally got it running with a new makerx. All part of the learning experience :sweat_smile:

1 Like