Why my Vesc creaking

Why is the motor creaking as I slowly push throttle?

And then in real-time data it won’t spin using the keyboard and will just do a single click.

And the ADC throttle mapping jumps a lot. It’s not the throttle that’s the problem and tried another

If I get out of ADC and do “no app” it runs fine on keyboard and no clicks.

1 Like

This is because you need to set Control Mode to Off and then toggle on the keyboard control on the right side.

The videos don’t work, try uploading them to YouTube or setting your phone to “Compatible”.

2 Likes

They only work for people with iPhones. Saying they don’t work is incorrect. It was developed by MPEG, yet Apple was the first adopter.

What are your motor detection values? @hummieee , sounds like it might not have done detection correctly.

2 Likes

so they…don’t work for everyone else.

5 Likes

ive tried all kinds of control modes. ive swapped out the esc for another and same settings and it’s stable. i crashed, on the table, and banged the vesc pretty hard and think maybe i damaged it.

I think something else. The motor is smooth when without any control mode.

I think ADC is damaged. The plug took a big hit.