Why does my board turn off when I move the wires?

I tried turning on one vesc alone and after that they stopped working for hours and I thought I destroyed them… Now I am not touching anything because it feels like magic when they turn on and off can someone who had similar problems please help me?
@tinp123 @pjotr47
Should I resolder the parallel connector cause there seems to be the issue or is there some interference from the wires which are close to each other?
A video what happens: https://youtu.be/DAMK4nGatWg

1 Like

Try isolating the issue.
Plug in just one ESC and if it doesn’t do the same thing, move onto the next ESC.
If it happens to both individually, then there’s something wrong with connection either at the XT90 or at the solder joints before that
If it happens to just one, then work your way up from the parallel connector

1 Like

I will have a look at them one by one tomorrow hopefully it does more predictable things then… because after trying each one individually to find out on which side of the cable the issue is, the bottom one worked once and after that none worked no matter what I did until 1h ago…

Did you try testing them separately? Dumb question but need to ask

Yes, the weird part was, that the bottom one turned on once, then never again and the top one never turned on… something really weird is going on here…
They suddenly started working in dual config after maybe 50 tries on and off…
This made me freak out…
I will redo every single connection except the one inside the vesc cause I would have to redo the silicone then and will go from there…

1 Like

You have a loose connection or bad solder somewhere before the vesc. Not once have you mentioned that your battery is reading a charge, have you checked that yet? If you don’t have a voltmeter, get one and learn how to use it (it’ll be your best friend for diagnosing issues).

2 Likes

Could you try your VESC separately on a power supply instead of your battery? Sounds like either bad connection, bad battery or bad BMS to me

1 Like

Battery is all good… the diebiems reads normal voltage…

2 Likes

My bad.

Try a different battery lol.

Should be bad connection… I will redo them but what I dont get is, that both turn off at once… is this because of the canbus? Should not only one turn off when the connection is bad?

1 Like

You can check that with split ppm

I feel like I am stuck in a maze :smiley:
I will update you tomorrow what the outcome of my troubleshooting is…

2 Likes

This has all the signs of cold solder joints in the XT90 connectors.

Do you have high-resolution photos of the solder joints?

Every time you solder any wire, after it cools, try to yank the wire off. If you can pull it off, it was a bad connection and needs to be redone anyway because it will fail later.

7 Likes

I am starting to think that it is the bms… tried every single cable with an external battery and multimeter… they were fine… battery works also flawless so it must be the diebiems… can I send you some highres pictures to see where the connection of the bms is sometimes not working?





1 Like

It wouldn’t be the BMS if it was acting like the way in the video you posted. Unless the wires to the BMS were moving then there wouldn’t be that disconnect and loss of power to the ESCs.

Really, you should be working to isolate the problem. Make one step at a time and test one thing at a time which allows you to eliminate the other possibilities.

It’s been mentioned go try testing the ESCs individually which removes the parallel connector out of the question. You should revisit that. Try one side by itself, then plug in the other ESC and review your findings. If they seem to work fine, then it’s the parallel connector (common issue due to poor soldering of parallel connection) or bad soldering in the XT90 just before the parallel connector. You can also just cut through the shrink tubing to look at the soldering.

If you believe it is the BMS, then you can connect a meter to the XT90 from the BMS and just starting wiggling shit around carefully. If there isn’t a break in reading, then it’s definitely not the BMS

1 Like

but on the output of the bms I only have voltage when the vescs also do… on the input I always have voltage…
Doesn`t it have to be the bms then?
Should I maybe bypass the bms to try if it is the bms?
Tried every cable with another battery without bms, no issues there…
And resoldered every connector one by one… no issues before and afterwards with them…

Troubleshooting is going horrible I have been trying to replicate the problem over and over again but there was no clear movement or cable that stood out… I have no idea how to go on…

Can you add me on Facebook and video chat

Or 6504078457 iPhone
4153412281 Android video chat

Or I can host a bluejeans or zoom

3 Likes