Vx1 just won't pair? Is it shot?

I have a vx1 and a vx2 both are giving me issues, the vx2 just simply won’t turn on or even vibrate after 1 ride of use, and my vx for some reason it simply just won’t pair on my stormcore or on the flipsky 4 i had prior to it, is this a common issue? I’ve ordered 4 remotes now due to this issue, a vx1 and vx2 to replace these ones, a puck remote, and the nano trigger remote for torque boards. Is this vx1 just unable to pair??

1 Like

What happens if you put it on the charger? It’s charging? Maybe the battery is just fucked or disconnected.

Did you make sure the receiver is wired up correctly. VX1 you can wire up in two ways, ppm or via UART.

If I put it on the charger it says fully charged. That’s what’s weird. But once I take it off it’s got no life, and it won’t turn on on the charger either. No response from the button, I’ve opened it up and the button is in fact making contact too.

Yea I’ve tried all selections. The weird thing is it had this issue on my flipsky 4 and that vesc was never changed from it’s bkb settings. And it was originally paired with it til I unpaired it and it never repaired

But even if it wasn’t wired correctly this would not stop it from actually pairing, it’s just gonna stop it from sending any working signal and recieving data

Vx1 I recently bought did not pair no matter what.
Old remote worked fine with the new receiver but not vice versa.


Something is going on with the vx1 but I’m a little mad the vx2 won’t turn on after 1 ride. I just bought it. I resorted to buying 4 remotes yesterday lol vx1 vx2 nano trigger from TB and the puck.