vesc tool "CanBus is not supported in this version of the tool" please help!

Bump. Help!!!

1 Like

have you tried other versions of the VESC Tool?


When you extracted the tool and ran the program the first time, did it create a folder named “osm tiles”?

I noticed this w tool 1.25 and always have to delete that folder before I run the program. Otherwise, it gives me issues w canbus and detection.


So I had this issue as well and resolved it after flashing the firmware by going to each ESC individually and making sure that the canbus is enabled on both sides. I set mine to something like CAN_1_2 (i cant remember exactly what its called). If its set as disabled, you will see this message.


Tried over 10 versions/firmwares. They are all broken. It’s something specifically between vesc tool and my computer. Ackmaniac works flawlessly.


Will check this out and report back after work. This is the first shred of hope for a fix lol.

do you a bluetooth module?
maybe get it real close version-wise and flash the firmware over bluetooth?

I’m grasping at straws here with ya…

maybe try a lynux version with linux running on a thumbdrive?

If you use the canbus function in the connections tab it gives this error.

Where you need to go for canbus functionality is in the lower left corner. They just magically appear there if they’re on the canbus line connected. Or there was a scan button… dunno… but that one works and it’s all you need

Also bluetooth android app is a lil bit more straightforward on this


oh nice one.

Can Bus is not CAN FWD. :slight_smile:

Wow so I’m guessing there was a computer with canbus connected to it and vesc tool operating directly on the can bus at some point. neat.

I “can” confirm using the CAN bus tab in connections I can get this error. never touched that tab before.

have used:

  • “Can Forward” at the bottom of connections tab.
  • CAN-> button on right side button bar.
  • or the new can device list after can scan on bottom of the left menu. ( vry handty. )

Yeah I can set those settings just fine but it doesn’t matter because the can forwarding doesn’t work. I cannot change the ID of either vesc in vesc tool so they have their default ID. When I try to can forward to the slave vescs ID it still doesn’t work. If I put in 1 as the can forward it tells me it can’t find the firmware and disconnects the vesc. Can forwarding does not work. In ackmaniac all these features work flawlessly.

1 Like

I do have one but I’m pretty sure I fried it. :smile: Can I even set all those settings from the app ?

1 Like

Still doesn’t work. It shows both vescs but I can’t actually interact with the second one. Can forwarding doesn’t work. The issue I have is very specific and is between my computer and the vesc tool. Not the vesc tool itself or how I’m trying to set it up.

It did make that folder. Deleted it. Going to pop open the board and see if it makes a difference!

So what are the IDs set to? setting 1 as CAN FWD address doesn’t work unless the other side is 1.

if you can’t change the id on the one you’re attached to via USB something else is wrong.

This is the message you get when there’s nothing at that address. so wrong CAN ID for second vesc or CAN not connected.

What IDs does can_scan find on the can bus? any? is it different than the one you’re connected to? ( in “app settings -> general -> vesc id”

Yes exactly. The slave vescs default ID is 75 when I can forward to 75 nothing happens. When I try to change it’s ID to 1 and hit apply nothing changes. If I can forward to 1 before or after trying to change the ID to 1 it can’t find anything. It acts like it finds ID 75 and is can forwarding but nothing happens on the second motor when I throttle. First one spins just fine. These features all work perfectly on ack firmware so it is not the USB it is the software plain and simple.

1 Like

The ID of the vesc is 44 for master and 75 for slave. I cannot change them in the vesc tool no matter what I try. I have tried every combination of can status settings I can and nothing changes. Also when I plug in any vesc single or not and I go to 5he input tool it does not give me the menu where I can select between " my settup has a single motor" or " my settup has dual motors and I am seting up the master " or " my settup has dual motors and I’m setting up the slave " ackmaniac gives me them just fine.

I have tried over 10 firmwares/versions of vesc tool to the same result as far back as 1.0 the problem is the vesc tool not working with my computer. The most common consensus is that it is a compiler issue that happened when they compiled the program for distributioncthat for some reason breaks with whatever specific variables my PC introduces. But ackmaniac motor tool works flawlessly Everytime. But I cannot use my Uart remote on ackmaniac. I’m almost certain that as soon as I have access to another computer to try it on it’ll just work like it’s supposed to :man_shrugging:

1 Like

Tried flashing you bootloaders moving fw can corrupt them. Do you have a swd flasher.

That sucks, and sounds weird.

Weird. That seems unlikely. and more like a misinterpretation of the “Can bus” tab related error message.

sorry you’re having such trouble.

On the small chance this helps here’s a video of what it looks like in vesc_tool 2.06 when things are working nice. and the myriad of things you can click related to can bus fwd.


@StriateZebra did you ever figure this out?

Does this help?

Did you end up fixing the problem you had with your esc?

1 Like