Vesc 6.7 non gira un motore

Ciao amici ho un problema con il mio dual vesc 6.7. stavo provando una nuova batteria (visto che sui cavalletti la tavola funziona ma se ci salgo sopra si spegne dopo 10metri) per capire se il problema era il vesc o la batteria, bene attaccata la nuova batteria ha iniziato a fare un rumore strano cercando di capire se era il vesc o il motore ho fatto un test di 2 minuti totali.
Ad un certo punto un motore non ha più girato ho provato a resettare e caricare di nuovo i motori con vesctool (smartphone) ma non mi legge il secondo motore.
Eppure le spie verdi e blu sono accese in entrambi i vesc. Sapreste aiutarmi?


The first things to check for motor detection are

  • firmware on the ESC matches the VESC tool software version
  • try switching the motors from one side to the other and run detection again
  • try running detection in other modes like BLDC

Could it be somehow a battery problem ? Do you use a discharge BMS ?

@SUNNYhaze forse puoi postare foto delle tue impostazioni e della tua batteria ?

The problem is now more the fact that only one motor will spin. He should try, as Flyboy suggested, swapping the motors around.

True, could be a shorted motor, but also could be a total lack of power, if the battery is the only new element it’s worth checking

1 Like

i tried to swap the motors with the result that all 2 work.
I moved the bluetooth module from master 1 to slave 2 and it connects and does all the procedure for motor detection except for pairing with the remote control.
at this point I think it’s a can bus connection problem because everything works singularly.
I have already tried to follow some advice found here Flipsky Dual 6.6 Can Bus not working PLEASE HELP! - #14 by bearlyrecognized but without results.

1 Like

I tried to connect everything via pc but also from vesctool on pc it connects me only one channel at a time, I tried to load the fmw without result. I’m trying to connect in all ways and now I get this message “CAN bus support is not enabled in this build of VESC Tool”
At this point I think it’s really a can bus connection problem, I’m following another post 44671/10 but without results. as already said I believe that the problem is to be found directly in flipsky.
aside from the jokes I am also contacting flipsky which is a bit slow but always responds.
if you have any ideas about some tests to do, please tell me now I will try them all before giving up and throwing everything away.

maybe try an older firmware of vesc and older version of vesc tool, had similar problems with can communication not working correctly on a dual 6.6 and fixed it by using an older firmware and older version of vesc tool (look there Beginner Question Thread! 2022 Edition - #2526 by jaykup).
Program the software on each side individually

1 Like

hi guys I have been in contact with the flipsky service center for days and at the end after sending them a video with the engine setting and calibration procedure they came to the conclusion that it is broken and they will fix it for me. it’s good news but I’ll have to wait months now to have the ecu in behind. i’ll keep you updated on what they’ll do to the ecu.

in the meantime I will wait for the return, do you know if there is any discussion on the Chinese esc control units? because I have one but by now it is cooked and I would like to fix it to mount it on my daughter’s jeep, obviously with engines and 3D printing all the components such as gears / supports and covers