Troubleshooting an old build

I originally finished my first and only build in early 2019. I rode it a few times and everything seemed fine. Let me friend ride it. He came walking back. I was able to fix it, but I don’t remember what the problem was. The next day I let him ride it again, he came walking back again. Sigh I actually am unable to troubleshoot the issue, even after a couple of weeks of trying. I can’t remember how much I involved the forum with it, maybe I thought I could figure it out. I never did. Life got busy and I eventually forgot about it.

I want to ride again. I’m back at it, but I unfortunately forgot most of the information I binged over the 3-6 months that I read up on at the time. I’m trying to refamiliarize myself, but it’s a bit overwhelming. Learned the Unity, which I got in one of the first batches, is now defunct along with Enertion. I apparently fried it. So I got another VESC. I’m terrified of frying this one too, so I’m trying to be careful. I believe one of my issues is with the battery, more specifically my bms. I think.

Here’s where I’m at. With the Unity, I could power it up, but I couldn’t do anything. I couldn’t connect to the Unity via bluetooth or plugging it directly in. That’s when I found that it was most likely fried. So I’m getting that checked on, I got a new VESC because I’m impatient. It won’t turn on for longer than a second. So I take out my battery and check the voltages. Boy, the readings don’t make sense to me. Like I said, I think what I gather is the bms must have goofed? I know when I assembled it, I tripled checked that everything was good and even. Maybe I’m not measuring correctly, but I measured the voltage on the bms like this;
-b to b1 = n/a
to b2 = 3.09
to b3 = 5.6
to b4 = 10.12
to b5 = 13.64
to b6 = 17.16
to b7 = 20.6
to b8 = 24.1
to b9 = 27.6
to b10 = 27.1 wtf??

I honestly feel like a complete noob and I hate it. I’m stuck. I tried searching around and relearning the stuff from before. I’ll provide more information or pictures if need be. I just wanted to get started.

If 27v is total pack voltage, a balanced pack would have each group @ 2.7v. From that I can assume your pack is unbalanced. Your bms could very well be faulting due to low voltage and not allowing current to the ESC.

I’d start @ the battery and go from there. Either get the pack balanced or get a new battery. Theres a few battery builders here that could assist with balancing if you’re unable to yourself.

lol, I was just reading up on some of my old topics and you were one of the main ones helping me with my battery first time around. I just realized I left out a lot of crucial information in my post.

It’s 10S4P 30Q battery pack. I built it, didn’t really even go through more than a couple of charge cycles? before it broke. It would just be easier to say my friend is cursed and my board hates him, but most likely a fault on my end during my build.


Do you have pics of the battery construction?

1 Like

With it working for a few cycles and then not, and seeing your groups voltages, I can assume the groups weren’t balanced upon building the battery or the bms went to shit on balancing and let them drift. Either way, the battery should be the first thing you look @. Once you resolve your battery issue (which I do believe is your overall issue), ESC will get power.

If you’re not that savvy, I’d say get it to a builder and let them assess it. Could be as easy as balance and done. Or it could be that those cells are just gone and a whole new pack is needed.

1 Like

This is an issue. If this is a 10S battery there should be 10 numbers. The first step is getting all these CAREFULLY without shorting anything out.

B- = B0
B+ = B10

B- to B0: 0.0V
B- to B1:
B- to B2:
B- to B3:
B- to B4:
B- to B5:
B- to B6:
B- to B7:
B- to B8:
B- to B9:
B- to B10:


You got it boss. I’ll do it when I get home this evening after I double check that’s what I’m measuring. I know for a fact that everything was good before I assembled it. I’m too meticulous for my own good sometimes, so I know it was ready to put together. I must have goofed with assembly or something. I mean this thing has been sitting for over a year and a half.

So the numbers are basically the same, but I’ll still put them up again. These are too low, is there no hope to charge them up again? I assume if the bms is working, it’ll correct the voltages?

B- to B0: 0.0V
B- to B1: no reading
B- to B2: 3.10 V
B- to B3: 6.61 V
B- to B4: 10.12 V
B- to B5: 13.64 V
B- to B6: 17.16 V
B- to B7: 20.6 V
B- to B8: 24.1 V
B- to B9: 27.6 V
B- to B10: 27.1 V

Okay, I been doing some more research and calculations. Ideally I wouldn’t want the overall battery to go lower than 27.4 V but definitely don’t want to sink past 25.7 V? I’m not 100% certain on that, but that what it seems to be with the information I found. I still don’t know why the first pack and last pack are wonky like that. I want to say just because they sat there for nearly 2 years rather than being drained a more traditional way. Theoretically this should fix itself by charging it? I don’t want to disassemble the entire pack if I don’t need to. It’s not anything near professionally built but I think it was solid for a first go at it and I took extra care to assemble it safely.

Took me two days before I eventually measured it because I was terrified of shorting it. Didn’t do it until I was certain on how I was suppose to do it.

You don’t want “any single P-group” to fall under 2.5V or preferably 3.0V


Alright. I got the battery working again. Turns out the tabs for where the wires for B1 and B10 were loose. Attempted to spot weld them back but I never fully fleshed out my spot welding skills or have my settings tweaked. Instead of bothering with that right now, I just soldered them. I know it’s really not ideal for the battery but I just didn’t want to mess around.

The VESC booted up without any problems. I have the switch plugged in because I don’t know if there’s a way to “short” it like I could with the Unity and have the board power on and off via just the loopkey. I tried looking and couldn’t find anything, so just opted for loopkey and switch combo.

Now I need to figure out my remote situation. I have a Firefly remote I built but never got it to run. More than likely an assembly error rather than it never working cause my board was messed up elsewhere. I have a nano remote. It’s not ideal but its what I have. Either way, I’ll try to work on that later. I’m tired from repairing my battery all night while trying not to blowing myself up.

What VESC?

Oh, I got a Stormcore 60D.

1 Like

Those weld do look a little weak. What welder are you using?

They are definitely subpar, but I think they will hold for now. With the series being reinforced with braids, lots of tape, and being heat shrunk. It should hold enough for some preliminary rides. I have a boss spot welder, iirc. The homemade Korean one?

I do remember trying to tinker with the settings and not fully figuring out the most optimal ones. Any advice would be much appreciated, especially pertaining to this particular welder.

Ik think your problem is the battery… I have had troubles with lipos on my kweld. Try and use a car battery maybe? What thickness of nickel are you using?

Ik know people that have had luck with this Lipo.

The one on my battery are .15mm thick. I just got a really nice digital caliper for Christmas, so first time actually knowing the thickness. Though I might have known it was .15mm thick when I bought it. I don’t actually remember.

I opted for lipo because I don’t have a garage, so I didn’t want to have a giant ass car battery just chilling inside the house. I suppose I could make an exception. I can’t remember, have there been people using car batteries with this particular spot welder? Seems almost overkill. This lipo does have a high discharge rate. Oops, just saw you posted a link with an even higher discharge lipo.

1 Like

I use a big 12v Bosch battery from my old diesel car, gives me about 1300A weld current, which is just enough for 0.3mm nickel!