Remote cutting in and out/delayed response from board.

I just put my board back together after fixing the anti spark switch, and the remote wants to cut out intermittently/stop accelerating/brake a second or so after i use my remote to brake and have already let go. Same with accelerating. It accelerated after I had tried and let go and it caught me by surprise and just about caused me to lose it. Lol. Looking for a fix. The remote is just one of those mini remotes with a hole for the finger. It’s a couple of years old now. Do i need new batteries in my remote? Has my receiver just been vibrated to death? Should i just get a new remote? Is this just something I can mess with in the software? I bought this board from someone who built it so I am reverse engineering everything and learning to be an esk8 mechanic bit by bit. Thanks for any help!

1 Like

Something that has caused this exact problem for me before was the signal wire (the white one) coming from the radio receiver to the ESC had a loose connection / broken wire. It got smashed under the ESC when I bolted it down.


I’ll open it back up and move things around and see what I can find. It’s weird because it only does it when I’m actually on the board riding it. If i just run the motors with the wheels off the ground, it’s fine. I can’t get it to screw up. As soon as I get on the thing and try to accelerate, after a bit of speed it cuts out. I may just go ahead and get a new remote/receiver. The flipsky vx1 looks decent.

1 Like

I can highly recommend the vx2 pro if you have a free Uart port. Are you sure it isn’t an ESC issue though ? Does the motor just cutout for a split second and then come back ? Does it always happen or just when you start riding ?

Also what ESC are you using ?

I am not sure exactly what it is. It happens consistently, not just when i start riding. From not moving until full speed, it will cut out maybe 3 or 4 times sometimes. It does this pretty much every time.

I am not sure what the issue is. I am using 2 of these.

1 Like

I’m not sure if the VX2 is compatible with this VESC. This says it is based off of 4.12 and I think the VX2 is 4.20 plus.

Hi Guys, just wondering if there was any solution to this? Also having the same issues.
I’m also using Maytech 50A SUPERFOC6.8 VESC.
Sometimes the brakes dont work when i ride, and acceleration sometimes has a delay in response and also jolts sometimes. I have also tried moving my remote received outside the case to make sure i get a stronger signal and no signal interference but still the same issue.

Try moving to the receiver to the other vesc?
Idk are u also using a flipsky remote?