(Noob) asking for some help

Hello All,

I’m currently in the process of building the following.

12s4P 30Q / Stormcore 60d / Flipsky 6355’s on a DB 37" downhill deck

I am currently running into issues since unplugging the DAVEGA to get the power to turn off (Power switch stops working when DAVEGA connected for some reason) now I the vesc is no longer able to find the motors when running the FOC wizard or BLDC.

I get

Faults recording in the VESC App.

The following faults were registered since start:

Fault : FAULT_CODE_DRV
Motor : 2
Current : 0.1
Current filtered : 0.0
Voltage : 49.77
Duty : -0.001
RPM : 14.2
Tacho : 15
Cycles running : 2
TIM duty : -23
TIM val samp : 8410
TIM current samp : 8400
TIM top : 16800
Comm step : 0
Temperature : 28.50
DRV8323S_FAULTS : No DRV8323S faults

Fault : FAULT_CODE_DRV
Motor : 1
Current : -0.5
Current filtered : -0.0
Voltage : 49.74
Duty : -0.002
RPM : -279.3
Tacho : -3
Cycles running : 4
TIM duty : -39
TIM val samp : 8409
TIM current samp : 8400
TIM top : 16800
Comm step : 0
Temperature : 28.50
DRV8323S_FAULTS : | GDF | FAULT | FETLA VGS |

I"m unsure what the issue is, any advice would be appreciated. I tried to reapply the FW, but still getting the same error.

2 Likes

If you unplug the Davega and re-configure everything without that in the system, does everything work normally?

Perhaps you have your inputs set wrong? The input mode should be set to UART & PPM or just UART. If you have the input set to PPM only, then the Davega will not work (though I dont see why it would be causing an issue like this.

@janpom have you seen anything like this before?
Perhaps @Deodand could chime in on the stormcore side if he has a minute?

1 Like

I’ve unplugged the DAVEGA and reset all default settings along with FW. I’m still running into this error now.

When the DAVEGA was installed it looked like it was working, but I had the following issues.

  • Stormcore power button stopped working
  • Battery indicator LED stopped working
  • Throttle on remote would act really strange

Thanks for your input!

1 Like

What remote are you using, and how is it connected to the stormcore?

1 Like

Hey Duck, @Enjoimangos is a local homie of mine, thanks for helping him.
He’s running a puck, I assume hooked up to ppm.

The weird part to me is b4 it was working w/o davega hooked up, and now its throwing drv faults after messing with davega.
What usually causes drv to blow, if that is the case? Phase wires touching? Too high settings

3 Likes

I’m using a Hoyt puck and it’s connected via the PPM connection. The only other thing plugged into the SC right now is the Power button that comes with the vesc.

I can configure input no problem, but my motors won’t detect, I tried another set of 6374s I have that didn’t fit this board and same results with the error reason -11 during motor detection.

No worries! Doing my best, but I suspect this is going to be above my pay grade lol. Hoping that @janpom or @Deodand can come save the day haha.

Those are the two main causes I know of. I would be shocked if his DRV is actually blown, more likely there is just some bug causing the error. Getting a DRV error does not mean your DRV is blown, for the record.

Gotcha. Go to “App Settings” -> “General” -> “APP to Use” -> and look at what is set. Since the stormcore is a dual VESC, and you are using VESC Tool, you have to configure either side independently. Whichever side has the Puck plugged in should be “PPM” or “PPM and UART”. Whichever side has/had the Davega plugged in should be either “UART” or “PPM and UART”.

That does not solve your current DRV issue, but just good to know for the future, in case you did not.

I was battling this same problem a while back with my first build. What FW version is on your Stormcore, and which VESC Tool version are you using?

Also, I would like you to take a multimeter and test for continuity between your motor phases. Test with the motors disconnected from the stormcore.

The last thing that occurs to me is that perhaps you fuckered your FW with something you did (this is unfortunately easy to do with VESC-based FW in my experience. You may have to try re-flashing via SWD port (though this is a big ass-pain, so hopefully not).

Just to clarify, you said that you did flash a fresh instance of the FW to your stormcore since the problem started? Did you press the “Upload to all connected VESC’s” button, or just the singular button? (these two:)
image

6 Likes

Yeah I had the app information configured as you stated. I’ll need to pickup a new multimeter, darn puppy chewed it to hell and I never replaced it. When I updated the firmware I pressed the button to the right with (arrow down + All) to apply to both sides of the VESC.

1 Like

Hmm, well that’s pretty much me stumped. I’ll ask some folks about this, see what they make of it. Out of curiosity, have you tried using the Stormcore app? I dont actually know a ton about Stormcores. Single MCU dual VESC’s are still magic to me.

Perhaps you should try posting about this and linking to this thread in the stormcore thread? That might attract the attention of some folks who know more than this sorry old Duck :sweat_smile:

1 Like

@BenjaminF no problem I appreciate the input. There’s not much the stormcore app does regarding settings from what I can find, it’s mainly just a quick view of the VESC and it says my device is healthy with no faults.

1 Like

The Davega works fine in my flipsky dual vesc so it must be something with the SC. I’ve contact Lacroix to see if they can be if any assistance with my DRV error.

Tested both motors on that vesc as well no problems. Glad I have a backup :slight_smile:

2 Likes

Yeah thats super weird. LaCroix will straighten you out though, they are A+ gents :grin:

2 Likes

They are sending me a replacement 60d :slight_smile:

4 Likes

Awesome dude :sunglasses: LaCroix are good people.

Here’s hoping that fixes it :crossed_fingers: Did they have any ideas what might have gone wrong?

Nope they have no clue. We did some troubleshooting and they said they would get back to me, few minutes later I get shipping noticed for a replacement VESC.

Thanks for the input @BenjaminF!

3 Likes

Any time :grin:

Got my new SC 60d in the mail today and everything is working like a charm. I must of had a faulty unit cause it was acting WEIRD even when it was working, but I hear that’s common stormcore thing :smiley:

1 Like

Thats awesome to hear! I hope you really enjoy your esk8 :grin::metal:

Yeah I have heard of lots of little weird things with the stormcores unfortunately :thinking: thankfully LaCroix is an upstanding company who can take issues like these in stride. Hopefully they are also learning from them and refining their product and manufacturing process.

1 Like