Motor spins on vesc test but stutter on manual


Uploading: VID_20230331_033131.mp4…

This is a small test motor didnt waste much time to make it prettier than this :neutral_face:

I’m using MKSESC 75100 did the motor test and it spins normally in the test wizard, in the flux linkage measure it spin just fine, but doesnt spin no no matter what I change, sensor mode , bldc or foc, duty cycle , current, RPM it only stutters

What’s goin on ?

The second vid didnt upload for some reason

Set it to sensorless, spin it up by hand to start it off and see how it does

same stuttering

Has this motor been tested with other escs? Is this an off the shelf motor?

What esc is this exactly?

The google machine found this

https://m.aliexpress.com/item/1005004858507542.html

1 Like

flipsky 75100

1 Like

You try re-orientating your phase wires for shits and giggles?
I have a set of motors that only work one way apparently. Atleast on 6.0 I haven’t tried it on 5.3

Also doesnt that motor technically go beyond our esk8 motors for detection?

I built this motor myself and its the first time I deal with ESCs , so this motor isnt tested on any other ESC, but i believe its working properly as it spins smoothly and silently on the VESC test wizard and flux linkage as i showed in vid

what do u mean by ( re-orienting)
i tried swapping phases only it reverses direction
and its connected in star ( Y ) pattern
I wound all of coils in the same direction and I swapped connect the middle set of coils ( phase of 240 degree )

well … about detection its already detected by the vesc software as shown in first vid the vesc test spins it smoothly but i cant spin it manually and I’m so sad , watched some youtube and read some topics none helped , I dont even know what or where to start tweaking as the vesc has sooooo many things to play with

Like at the bullets.

So vesc software should re-orinetate them. But I’ve ran into a pair of motors where they tested fine but would be wonky. Just moving the bullets to different phases made it work.

Example

1 2 3 = 1 2 3 was my start
1 2 3 = 3 2 1
1 2 3 = 2 3 1

No it doesn’t work either :disappointed_relieved:

can’t see the videos on chrome or android

I had a motor that was refusing to spin up when it’s unloaded, but was working fine other than a few ABS_OVERCURRENT faults while loaded. After I changed out all the bullet connectors to brand new 5.5 mm ones, it started working flawlessly again. You could also try just cleaning the bullet connectors with isopropyl alcohol before changing them out

1 Like

Well… After many failed attempts , I decided to attach hall sensors to that motor , and it worked smoothly at last, I believe this motor doesn’t like to work alone :joy::joy:

Thank you all for your time love you :hugs::hugs::hugs::hugs:

2 Likes