MaxkGo BMS Voltage issues over canbus

I have recently purchased the 12s MaxkGo / Flipsky BMS, which seems to run of a branch of Ennoid, tried both Ennoid and DieBieBMS firmware with different levels of success (all having issues of their own), but the MaxkGo firmware seems the most compatible one, it seems to hold all the data and voltage pretty okay.

However when communicating with the VESC, it has 1 issue, it sends to the VESC that group 4, 8 and 12 have 0 volt in them and I have tried updating the Spintend Vesc with latest 5.2 from Spintend, gone through both Ennoid and DieBieBMS firmwares and now back to MaxkGo as they werent 100% compatible.

If anyone has any ideas, please tell me as I’m getting pretty tired of not figuring this one out, feels like I’m missing some basic info or setting on the Vesc side, having tried almost every setting I can think of in their BMS tool without sucess.


Have you actually measured the P-groups? Are you sure they aren’t zero?

1 Like

Yes, double measure, triple measured and verified directly with bms cable, directly at the cells and with the BMS software aswell, so nothing but the VESC says there are 3 groups at 0 volt

1 Like

Does MaxkGo have any suggestions?

They have sadly not responded yet to my inquiry

1 Like

do you have the original maxkgo firmware still? or know where to get it? I’ve been searching and having a lot of issues. I tried upgrading to 5.4 and reset parameters but, no matter what i do i still have a power up failure. I’d like to just go back to stock and restart. Thanks

Here is my current settings. Maybe I’m missing something.

I sadly tried everything I could with this BMS, to hell and back I would describe it, tried Ennoid, MaxKGO and DieBieBMS firmware, I contacted Ennoid and conclusion seems to be that this BMS may be faulty by design as several people have issues getting it into a charge state and it seems to be a fault by design.



That’s irritating…damn. Thanks man