Massive connection problems with stormcore and iPhone

Hey all,

I’m having massive connection problems with the stormcore in my Lacroix Nazaré (D60+) and my iPhone.
It sometimes works but most of the time the app can’t find my board.
Sometimes I can connect when I quit apps running in the background, switching BT off and on again does not change anything.
Is there something to watch out for?
Could it be due to my Apple Watch being connected via Bluetooth?
I’ve never had problems connecting to my Onewheel.
Thanks

2 Likes

Were you able to resolve this issue? if so, what was the problem? It sounds like maybe the BT module wasn’t working.

1 Like

For what it’s worth, we’ve found that log transfer speeds over BLE with the Robogotchi get heavily impacted by having multiple BLE devices connected simultaneously.

If it’s not finding your board most of the time, that is usually signal strength related and I’m not sure connected devices would have an impact like that. A stock Nazare should show up fine- have you contacted LaCroix about it?

1 Like

Tl;dr: it sort of works but only sometimes.

Well, now I have found out that killling other apps running or being idle in the background helps but only sometimes.
What really helped was rebooting my phone, then I could connect to the Stormcore but not the Xiaoxiang BMS.
After another reboot I was able to connect to both.
I know where the antennas are and I held my phone very close but not too close to them, I noticed in the past that keeping things connecting via bluetooth directly next to each other does not help connecting.

A week or two ago we had three big storms in rapid succession here in Europe and after that a lot of things electric and electronic acted up.
I wanted to charge my board for example and the charging indicator lamp would not turn red and it would click and click and click and not charge.
After I tried connecting to the BMS it suddenly sprang into action like it was turned off and the charger worked and the board charged.
I had connection problems before, though.

The problem is that nearing the end of my ride I need or want to know my accurate charge level so I know which way I can take home, the Davega unfortunately is more like a guidance, it says I have one red bar left when I still have 40% charge and once it said I have one red bar left but all of a sudden the stormcore said 0.1% and I only had like walking speed left.
I entered the correct value as given by Lacroix and even played with it a little but it is not that accurate.
For example I have the standard 200mmm wheels but I have to enter 185mm or the speed is way off.

I have not contacted Lacroix about it because between them ans you guys here, you are much more knowledgeable it seems than the guys who built it.
The guy selling them in Europe is not better, communication is minimal.

Never used the stormcore app to track rides as i use Yours Truly, but i know if YT grabs a connection (which it does instantly because i have auto-logging enabled), then i won’t be able to go into stormcore to connect, because its being used by another app.

Other than that YT works flawlessly with my apple watch and the automatic logging upon startup is nice.

1 Like

YT is what I use as well, great app and it always works with my stormcore, it does not show battery level though, or am I missing something?

Gotta input your battery metrics to display an accurate reading

I did but I’m not sure it is correct or I put them in correctly.

Feel free to upload some screenshots of your battery settings and we can try to see if there’s anything that needs updating

Will do when I’m home, thanks.

1 Like