Is my ESC fried?

I have a flipsky mini fsesc 4.20 and I turn on power and my vx1 receiver lights up, but the esc doesn’t. It started doing this after I made some changes on my board, but I hadn’t turned it on when I was doing that. What could be wrong? Is it fried?

Could be a loose connection.
No lights is tough though. It’s very possibly fried.
Do you have a way of measuring current going into the device?

Although the esc thing is weird.
They run 3.3v but the drv runs 5v so it’s possibly just the step up converter on the esc… Hard to guess without diagnostics

Have you tried connecting to pc?

Not yet, I’m trying to find a multimeter I won’t fry. I’ll try connecting to computer anyway

1 Like

Is there anything you did while making your changes that could have fried the vesc such as maybe touching a metal screwdriver to you pcb with power on? can we get pictures of the set up?

1 Like

You’d have a hard time trying a mm as long as the leads are in the volts position. That’s a hi impedance input and short of a lightning strike, should be fine to use


What changes did you make to the board?

Motor is a sk3 6374, I didn’t plug anything in or out other than motor cables, and it still has the shrink wrap so I don’t think I would’ve accidentally touched it. It is kinda dirty, because my last enclosure sucked and wasn’t sealed, so I guess it could maybe be that?

I plugged it in and the computer couldn’t find it. I’m guessing no power runs through the board maybe

Just moving from sketchy taped on enclosure to bolted on. I took the meaty electronics out in one chunk while I worked on the enclosure.

It’s saying a good 41.7V of power is moving through there. I don’t know what is keeping it from the rest of the board

I did have a fsesc 6.6 that fried while i was on a sidewalk because it was a shitty enclosure. found some water/debris on it

Should I dust mine off? Will that solve it or should I just get a new one?

whats that loose cable to the left of the vesc?

We don’t know that the debris is the issue yet

It’s less about volts and more about the current.
Does the big black chip get hot after just sitting there? Or warm?
Does it smell like sulfur?

Those fsesc things are just inevitably going to go kaputt.

The cable for the vx1 to solder to the power so you can tell from the remote how much is left in your battery

1 Like

A lot of them do, although ive been running 50+ amps through my 4.12 for a while and its still going good. Also its kinda weird that it stopped working after some changes.

1 Like

No smoke, no heat, no sulfer. I’m trying to find a different multimeter this one isn’t rated for high amps. It might be fried but idk what part ditched. Nothing seems visibly degraded.

Actually wait, there’s heat from the chip, but nothing is frying.

is it barley noticeable? or hot to the touch?