How to flash a VESC 4.12 on Mac?

Anybody know how to flash a VESC 4.12 on Mac? I’ve got a TB 4.12 and wanna run Ackmaniac. I found software to run Ackmaniac on Mac here:

But I’m not sure how to flash on a Mac. I’m new to all this =\

Buy a pc lololol

1 Like

Use bootcamp

1 Like

You flash the firmware the same as you would on a pc

1 Like

My bad, I thought you meant with a ST-link to load the bootloader. Were you able to download ackmaniac? I have the download that I used to get it still. Let me know if you need it, it has worked for me fine on mac.

I don’t even know what a bootloader is exactly clearly I need to read more on VESCs. All I know is I got TB 4.12 and I asked Dexter and he said I need to flash those VESCs to use Ackmaniac. And I found that ackmaniac for mac on the builders forum but I guess I don’t know what the difference is between a bootloader, firmware and the software and everything. It’s hard for me to sort all this stuff out sorry lol

1 Like You should be able download Ackmaniac from that link. You just click on the zip file and it will extract the application. When you open it there is a “Firmware” tab, you go there and load the Ackmaniac firmware onto the VESC, it will probably say right away you need to load the firmware before you can do motor detection anyway. Make sure you choose “Hardware Version”… " Select 410 & 411 & 412."

TB has a tutorial to show you it looks like, The steps should be the same/very similar for the Ackmaniac too

Is that what “flashing” the firmware means? Just updating the VESC with the firmware require? Or is that something you do after flashing? What is a bootloader anyway? There is a bootloader that comes on this VESC, but are some bootloaders made to work with VESCtool and other with Ackmaniac? Or how does that work?

1 Like

Yeah I believe that is what that means. If you ever brick your VESC like the hardware is still good but the software piece is corrupted and doesn’t work aka bricked. You can reinstall the bootloader to get the VESC back up and going. The bootloader is the first piece of software the processor uses when it is powered on. I am really not too sure what it is I just know you need to reinstall it if the vesc doesn’t work due to a software complication. All VESCs you buy will come with the bootloader already installed so usually you dont have to worry about that.

1 Like

my main concern is reading this from the other forum’s VESC guide:

" you need the bldc tool with the same firmware as the one pre installed on your vesc . If you are unsure which firmware your vesc came pre installed with, ask the person you bought it from, or download any version, and when you attempt to connect your vesc to the bldc tool, you will get an error which will tell you which version of firmware you have. For instructions on connecting your vesc, read below.

You can update or downgrade the firmware to match the version of bldc tool you have, but this should be a last option solution if you really can’t find the right tool. You can fry the drv chip on your vesc by doing a bad firmware update, which is very easy to mess up, and would make your vesc an expensive paper weight."

If I’m understanding correctly, “BLDC tool” refers to either VESCtool or ackmaniac right? And TB vescs do not come with Ackmaniac FW preloaded, which is why Dex told me to flash (I’m guessing)? So I guess as a noob I’m really scared I’m going to plug this sucker in, open Ackmaniac and load the FW on the VESC and fry the drv chip?

BLDC tool is the older version of the VESC tool and both of them are the service program/Interface on your pc which allows you to change parameters or upload/flash new firmware.
For every firmware release there is a new version of the vesc tool (bldc tool before) which means the vesc tool which comes with your firmware version will only work with this firmware and not supporting newer or older versions. Ackmaniac has his own vesc/bldc tool so you need this to work with your firmware.

1 Like

OK, so if I run the ackmaniac esc tool and it prompts me through the program to update my FW it shouldn’t fuck up the vesc should it? Once again, sorry for the gazillion noob questions I just know these suckers fry when people don’t know what they’re doing.

edit: which is me

Don’t worry it’s a bit confusing in the beginning but get clear the more you read and ask about.
On your vescs is now firmware xy. If you connect your vesc with the ackmaniac tool you want to use it says you that there is old/wrong firmware on the vesc because the ackmaniac tool you want to use just work with the firmware version which is included in the service program version.
If you now upload the firmware which you find in the service program it will work and don’t give you this message again. If you flash the firmware it’s important to choose the right file for your vesc hw. Others mentioned that before. If you load the hw 4.8 file on a hw 4.12 vesc the vesc will not work anymore and you need an st v2 link to get it work (would be possible via CAN bus and the newest vesc tool as well but that’s an other story).


That was super helpful, thanks. I’m guessing that’s what a “bricked” vesc is when u gotta use the stlink?


1 Like