esk8.news esk8 calc donate now

Flipsky VX2 Remote VESC Ramping time

I usually use VX1 remotes by on my latest build used VX2. Well I got it working as it works out of the box thru uart but the problem is I cannot change the ramping time or the throttle curve.

I spent last 24 hours reading everything online but it seems like some people are somehow using nrf or nunchuck mode to do that.

Well not sure how they did that as I tried both nrf and nunchuck mode but cannot change the ramping time.

Using Flipsky 6.6 dual btw.

1 Like

UART remote in newer tool is under “vesc remote/wand”. I don’t remember the exact name.

1 Like

Will be doing this tomorrow afternoon. Best of luck and hope to hear your stories of success.

1 Like

I tried Vesc remote but it doesn’t work at all.

Use nunchuk, I believe.

@BigBen Can you share some
VX-2 wisdom?

Is it the colour screen version or the monochrome version?

If you got the old version mine only worked on the middle speed setting. Didn’t find a fix to that either

It is the color model, I tried nunchuck and it would lock up my uart, I tried both sides of my 6.6. The HUGE problem is that Flipsky has only documentation on how to setup the remote only, there’s no setup guide anywhere online for VESC. Because I live on hills, the remote will not let me come to complete stop and it’s super dangerous if I can’t stop on a steep hill. My VX1 works fine with current mode.

I just basically want to adjust ramping time and set it to current. But the remote goes backwards super slow on flat ground and does not stop board fully on hills.

If I try nrf, it goes into pairing mode and not sure how to pair it. Tried using the remote pairing mode also no luck.

Why doesn’t Flipsky fix this? I asked them and they told me to watch their remote setup video wtf.

Are you modifying app settings on the side the remote is connected?

Yes that’s why i tried both uart sides. Kinda stumped atm.

I guess nobody knows most likely because no one actually can get it working correctly. I am gonna go back to VX1 for now. Vx2 is useless without ramping time and full backwards controls. Ugh.

switched back to vx1 ppm, sooo much faster and simpler. I loved the accurate vx2 readings though, i will try again on another time when there is an actualy video tutorial for it. Right now I am guessing everyone uses it the way it is with no control over the vx2 throttle mapping, ramp time.

I’m using vx1 via uart and forwarding settings over bluetooth to the remote side seems to work just fine…
One last thing, under vesc remote settings can you put in some stupid high ramping up values? Like 20seconds or something, see if it makes any difference. (And sorry if you already tried it)

How do u forward uart?? I will try high ramping values but it’s just gonna make your board accelerate and brake really slow. I just set it to 0.1 sec for acceleration because of steep hills here but 0.5 sec for braking as most of time braking is too much anyways.

Damn, 0.1s sounds scary. One flick of the throttle and you’re feet up. I meant those values to make sure the esc listens to what settings you input, not to actually keep them.
And i forward them on the mobile app. Connect to bluetooth, scan canbus, connect to the vesc with the remote on, modify stuff, press write and it’s there already

Oh no i am already using the bluetooth app, but can you tell me in detail which tabs you are using to control via uart? E.g. using Vesc remote tab, etc…etc. …

I live on steep hills, on 30% grade you will never have enough acceleration from start. 0.1 ramping time is great for that otherwise board starts really slow. On flat ground its probably way too much.

1 Like

Connect- scan canbus(select side with receiver remote on), app config, vesc remote, and it’s all there.
I just noticed that if i use anything else besides “fastest” mode on the remote, it does not use what i adjusted in the esc. This is on vx1

1 Like

I will try again but that’s what I did, no matter what I change nothing would change with vx2. I will let u know thanks.

Does the remote side of the setup have any adjustments like deadband? (I’m curious)

Nope the remote side is purely for setting your pulley, wheel, and battery sizes to get accurate mph kmh reading which is super accurate but has nothing on ramping, dead bands, etc…