Can't get Focbox Unity to work! Losing Hope!

Good Afternoon Guys,

Back Story:

Years ago I build an electric mountain board, with the old Turnigy 6364 190kv from hobby king, I went for the FSesc 6.6 Dual (The first version), used it to the point that I had to replace tires because they wore off and punctured the inner tube :sweat_smile: :rofl:

https://drive.google.com/file/d/19ypFd1srQOyCO_A-10cl76oVNdjUc3fW/view
https://drive.google.com/file/d/16-BLI5P0wh1X51Q8raIy37M38nN7bso8/view

Fast toward almost 2 years, and today I decided to get it going again for the summer. (Yes I know 2 years is way to much, but between moving houses and even countries I couldn’t enjoy the board as much as I would have liked). Downloaded the new Vesc Tool (3.00) and got a message saying firmware too old you need to update your vesc. I was like “ok, lets just update it”. I am now stuck of firmware 3.53. No matter what I do I am stuck on that firmware, most likely because I tried to go from 3.53 to 5.2.

I think I bricked my dual 6.6. Is there a way to revive it? I have tried to search around and found a couple of topics about “bricked 6.6” but the information is all over the place and I have tried a couple of things but still no luck and I don’t want to make it worse.

Both esc’s connect, both with blue and green lights on. I even tried with the can switch on, connecting the SWDIO pin and the SWCLK pin from one esc to the other to see if I could get anything under SWD Prog in the Vesc Tool.

Any help would be much appreciated.

The back story problem was fixed or so I thought. Decided to buy a Focbox Unity and new motors just to start from scratch. Installed the Focbox and the motors updated the firmware on the focbox and this is the result:

Motors spin during detection and everything but once configured they won’t spin. Another thing worth mention is I have tried FW: 5.2 and it does the same exact thing.

Any help would be much appreciated, been fiddling with this since 9AM in the morning. Losing hope that this board will ever work again.

Best Regards Nesquick

Dumb question but did you redo detection?

2 Likes

Hey man, big fan of your product.

Can you post a screenshot of the motor detection results you got?

5 Likes

There is no such thing as dumb questions at this point. :see_no_evil:

Yes I did redo detection.

1 Like


This is the detection on the vesc tool 3.00 a Windows PC.

what remote u using? or r u using keyboard control to test the motor spin?

1 Like

I am using flipsky vx1.

First detection says hall sensor. Second sensorless… So wich one is it?

3 Likes

did u do the ppm calibration?

2 Likes

Sorry @Sandels it does not matter at this point (I think) I have tried both ways and passes the detection with or without the sensors plugged in but then does not spin. Ideally I would like to have it with sensors.

Yes I did.

Some people just don’t get your wonderful sense of humour Justin :pensive::pleading_face:

5 Likes

Those detection results all look in line with what I’d expect from those motors. Time to look elsewhere.

Is this connected with PWM/Servo/“PPM” or with UART?

What is App_Settings > General > APP to Use set to?

2 Likes

Good Morning Guys,
Sorry I kinda disappeared yesterday, I was super annoyed with this and decided to give it a break.

Coming back to it this morning and hopefully I can get it sorted.

To answer @b264 it is set as PPM as you can see in the picture.

Any suggestions, things to try or things you guys want to see from the configs?

Best Regards

More information:
When I squeeze the trigger to go forward this is the real time data I get in the current tab.

Did you go through the app settup wizard and select the control type?
Or click the PPM tab there and set the control type there?

1 Like

I’ve been trying to help him out through one of my nexusboards support channels as those motors are from me - as far as I can tell, foc_openloop doesn’t actually work. The input works normally, the PWM values are applied because on a new boot up of the vesc tool, it’ll read like 1.756v or something as the max value.

After detection, where you can click the FWD/REVERSE and check invert, I think that runs foc_openloop to spin up the motors, and that doesn’t work. They spin during detection, but not after. I’ve kinda run out of thoughts as to what it can be, and suggested downgrading the firmware.

1 Like

Have you tested keyboard input at all? My troubleshooting suggestion would be to just use one motor connected to the left output of the unity, run motor detection with just that and then try keyboard input. If that works it’s likely a remote problem (potentially inside the unity?)

1 Like

or maybe try to roll back on 23.46 and see it the unity works from there

3 Likes