Battery won‘t charge anymore

Hey guys,

So my 12s4p Hurricane battery stopped charging….

The battery is still in the voltage range where it should be, how could I determine where the problem is?

I already checked the charger and everything else and it seems to be working, sadly…

I was hoping that the battery had no damage.

One more observation I made, when I plug in my makerx esc into the battery, it also doesn’t turn on.

See this post, maybe something similar…?

Yes I had the same problem, switched out the charging module with a new one meepo sent me.

It’s still not charging with that :frowning:

If the xt60 has no voltage coming out, it’s possible that the bms is at fault


You mean the one on the battery?
It is showing an voltage of 38

1 Like

so battery alone is 38v, but when u plug in the esc, esc doesn’t turn on? any chance u can measure if there is any voltage going into the esc?

1 Like

Yes that’s exactly true.

How would I measure that? :smiley:

1 Like

i would say to probe the V+ and GND terminal on the esc, but u will need to open the esc and also iirc the positive and negative terminal of the DV6 is on different side of the pcb. it could be very risky to perform

1 Like

Okey I think I’m to scared to do this… yet.

Do you think there is some hope for the battery as long as it’s not under a certain voltage ?

38v in 12s, so each pgroup is around 3.1v, its not the best voltage to sit on, but for short period its fine


It should be a bms problem if the battery outputs 38V, my charger 51V and it still not charges right?

1 Like

Yeah, right…

Thanks for the help, I really need a solution for this.

1 Like

yes, it does sounds like bms problem, but electronics are weird, it may not entirely bms’s problem.

have u contact meepo about this?

1 Like

Yes but they are kinda ignoring my mails since 2 weeks :frowning:

1 Like

bring it up on facebook group or reddit, there might be others with similar issues, which can grab meepo’s attention.

1 Like

Replace the bms after measuring the balance connector