Battery indicator stuck on 100%

So I just picked up a Raptor 2 in mint condition for an absolute steal. But the only thing wrong with it is the battery indicator is stuck on 100%.

The electronics have never been tinkered with, so its a possibility that maybe something has just come loose?

Anyone got any suggestions?

Have you tried changing the amount of cells the indicator calculates the percentage from?

Havent tried anything, only just picked it up yesterday, first test ride just now. How do i set it?

I got no idea but you’ll have to open the enclosure.

More than happy to open the enclosure, but would be great to have a game plan :rofl:

Also want to put a Metr Pro in there, is there a way of telling which Focbox is master and which is slave just by looking at them?

The one that connects to the receiver is the master :slight_smile:

Guess you just press some buttons on the back of the display to change it

1 Like

You may need to hold a button while turning the board on to get into the menu.


The power button on the Raptor 2 is a rocker switch under a silicone cover… do you mean a button on the back of the indicator?

Yes, there usually one or two small buttons on the back of the battery indicator pcb. Depending on which enertion use.

1 Like